Stunnel Broken in latest package update with development build.



  • I updated my 2.5 development build yesterday and noticed a new stunnel package was also updated.
    Unfortunately stunnel is now missing from my SERVICES menu and the ports I had set up before no longer work.

    I have uninstalled and reinstalled but it is still missing

    Any thoughts on the matter? I have tried searching for bug reports and other sources but have found nothing.

    I also tried reporting the bug in their pfsense online bug tracker system but did not find out where to do it.

    Stunnel doesnt seem so widely used so these bugs dont get reported quickly enough

    Thanks for all your help


  • Rebel Alliance Developer Netgate

    Looks like a PR introduced a line that ended up causing invalid XML.

    I pushed a fix and bumped the version, it should show up with the next round of snapshots. (or in a few minutes for 2.4.4-p3 users)



  • I greatly appreciate it
    Thank you jimp!



  • I had 2.4.4-p2 on a SG1100. Then I upgraded to p3 and stunnel was no longer in the menu. So I tried to upgrade to development 2.5.0 - still no stunnel in the menu. This also broke the SG-1100, and I needed support to reset the device serial number and MAC before re flashing the firmware would work.

    Now I am back to 2.4.4-p2 but when I restored my config, stunnel is back in the menu, but when I click it my tunnel config is not there, and the config files are not in their folders. When I click add, I am only left with a 'Save' button whick doesn't appear to do anything.

    When it was working, stunnel version (in my xml backup file) is reported as 5.47_2.
    But when I try and restore my config now, package manager is installing stunnel 5.47_3

    This is the only change I can see, and of course, unable to get back to stunnel.


  • Rebel Alliance Developer Netgate

    Doesn't matter if you're on -p2 or -p3 the stunnel package is the same. You should be on -p3. The problem in this thread has been solved. If you have a new problem, upgrade to the most current release and package version and post the details of your problem in a new thread.


Log in to reply