Problem with Fabiatech FX5420 and pfSense CD 1.2.2



  • Trying to boot pfSense on a Fabiatech FX5420 (AMD Geode 800 with 512MB RAM) using a CD in a USB DVD burner and it seems to fail during the boot loader - the spinner stops spinning. I wondered if it might be a media issue, so burnt a new CD (on that drive) and then tried again with similar results. Then I ran memtest86 and all seems OK with that.

    A Google revealed that someone had a similar problem with 1.2.1, so I may try 1.2.0. I've not done the research to find out what I'd be missing with that, but I thought I could at least ask other FX5420 owners what version they're running…

    Cheers,
    Alex



  • …a bit more info - when I try to boot other things like LiveCDs for various flavours of Linux, the problem appears that it can't find a Linux device that represents the CD (eg /dev/hda2).



  • Have you tried using the FreeBSD live CDs?  Given that pfSense uses FreeBSD, not Linux, that would be a more meaningful test ;)

    Start with FreeBSD 7.1 and see how that behaves.



  • You might have a "quirky" USB DVD adapter.

    I've documented elsewhere in the pfSense forums my experiences with a couple of different types of USB to notebook drive adapters. One type wouldn't work with older versions of Linux but would work with newer versions. This type didn't work with any version of FreeBSD that I tried. A search through the sources showed Linux had an extensive list of USB mass storage adapters with various type of "quirks" and workarounds. FreeBSD also had such a list but much less extensive.



  • Thanks for the suggestions. LinITX (supplier of that box) had a go with a machine in their office and did have to change a BIOS setting, but even when I made the same change, it wouldn't work on my box (which I now suspect is defective). Will have a go with a FreeBSD 7.1 Live CD, though - good idea.



  • Interesting! The FreeBSD 7.1 Boot CD booted just fine.



  • Try with pfSense 1.2.3 http://blog.pfsense.org/?p=377 as it's based on 7.1



  • Ah! 1.2.3 works just fine. Thanks a lot.

    I hope that others may read this and follow in my footsteps!

    I wonder, though, is 1.2.3 really stable? If not, when?



  • …although it doesn't work booting from HDD - I suspect something similar to the ALIX board problem referred to in the sticky.

    Unfortunately, the sticky seems to have an error in the manual steps section.



  • @thewinelake:

    I wonder, though, is 1.2.3 really stable? If not, when?

    See http://blog.pfsense.org/?p=377



  • Yes, thanks for that - I kind of realised my question had already been answered a bit too late (and hoped nobody would notice!).

    I'm a little confused about how 2.0 (formerly 1.3) relates as that seems to be based on 7.0, but our supplier claims to have installed that successfully.

    If we're not doing anything at all clever with our box (just plain routing - no firewall, no vpn) I'd guess that stability issues shouldn't be a concern.

    If 2.0 installs properly onto hard disk, then maybe that's the one to go for on this hardware.



  • Having read  the notes on 2.0, I'm backing away from that one…

    In terms of getting 1.2.3 to work, it has been suggested that I append the following line to loader.conf:
    hw.ata.ata_dma="0"

    But that doesn't seem to have worked.

    Getting desperate here...



  • The cause of all my troubles appears to have been the finicky BIOS of this box. The trick is to have one setting for when booting of CDROM and installing to HDD, and then change the settings back to Optimal Defaults after having installed.

    Oh, that as well as disabling DMA access to the HDD with appending of hw.ata.ata_dma="0" to the /boot/loader.conf.

    AND - you MUST unplug the CD drive (even if there's nothing in it and the BIOS is configured to boot from the HDD first!)

    It may sound like the bleedin' obvious to people reading this now, but it confused the hell out of me!


Log in to reply