Squid in 2.0 installs but doesn't work?



  • when i start a fresh install of pfsense 2.0 and try to install squid it goes through all the motions then at the end when it says "starting package" or whatever i get this

    Could not find squid.

    it shows up on my menu under proxy…...but doesn't have the page for cache settings....

    i get this instead

    Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69

    i've tried uninstalling and reinstalling but nothing works...



  • Ditto.



  • yes it is. there's still some problem with the web GUI of 2.0 but i still loved its efficiency and power. ;)

    try to SSH, and vi /usr/local/pkg/squid.inc and change cache setting, (and others) for squid. you can search in the forums too on how to do it. it's simply more powerful than just relying on the GUI.

    it worked for me.

    and more too, search about changing /boot/loader.conf for squid to be much faster.

    just my little cents… :)


Log in to reply