Vlan + DHCP Clients unable to get dhcp ? no errors? clients gets local 169.254. instead of 10.74.13 + 2.4.4-RELEASE-p3 (amd64)



  • Hello,
    We have weird issues on our vlan after we upgraded to 2.4.4-RELEASE-p3 (amd64)

    • dhcp v4 is enabled dhcpv6 disabled... running on vlan 12
    • computers are getting 169.254.12.122 even do the dhcp offer is there for 10.74.12.113
    • The system shows them ofline...while the client computer is down
    • no errors of any sorts in logs

    How do I figure this out. How do I enable the additional logs?

    For our largest vlan we setup windows dhcp server and turned off pfsens, but for vlan 12, we are trying troubleshoot it.

    What can I do next?
    Thanks
    Lucas



  • Do you have DHCP configured on the VLAN? You have to do that for each interface where you want to use DHCP.



  • Yes dhcp is configured on each vlan since we want to be under 250 ip's.

    The only relevant msg is :
    which I believe is related to me stopping and starting the service .

    /status_dhcp_leases.php: The command '/usr/local/sbin/dhcpd -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /etc/dhcpd.conf -pf /var/run/dhcpd.pid re0 re0.12' returned exit code '15', the output was 'Internet Systems Consortium DHCP Server 4.3.6-P1 Copyright 2004-2018 Internet Systems Consortium. All rights reserved. For info, please visit https://www.isc.org/software/dhcp/ Config file: /etc/dhcpd.conf Database file: /var/db/dhcpd.leases PID file: /var/run/dhcpd.pid Wrote 383 leases to leases file.'

    I'm forced to setup a backup windows dhcp server and disable the dhcp on pfsense...

    Troubleshooting on client, it keeps saying that it cannot get ip address ,and will use local 169.254 until it gets an address...

    There is a bunch of dhcp leases that are "offline"
    At one point we only had 8 dhcp leases online,


Log in to reply