Upgrading from 2.3 to 2.4.4-3 No Wan



  • Hi, I live in the UK and i have SKY as my ISP.

    I want to start of by saying that I am not an expert but merely a simple very novice enthusiast that have a Windows server with PFsense as a virtual machine setup for my home network. I try to learn but have limited time. However I like to play around with my 2 servers (1 being unraid previously Freenas) and I try to learn new things, but with limited time between work and family I can usually only spare a couple of hours every now and then, and these hours quickly get consumed with reading and trouble shooting.

    I have come here out of desperation as i have tried to upgrade my PfSenese from V2.3 to V2.4 several times over a year and I can never get it to work.

    Everything i have setup works perfect in 2.3 but i can never get WAN to work in 2.4, all the settings are the same, I have tried upgrading, fresh install etc however i can never get an IP number from my ISP with 2.4 (2.4.4-3 as of today).

    Is anyone aware of any bugs or special settings that needs to be applied with 2.4.4-3 that was not needed in 2.3 ?

    any help would be much appreciated.

    2.4.4-3 not working.png 2.3 working.png


  • Netgate Administrator

    So it is pulling a gateway IP address via DHCP but not an interface IP? Odd.

    Check the dhcp logs when it connects. I imagine there will be some sort of error shown there.

    Steve



  • This is the error i found in the log file

    83535dad-72e8-432e-a5d9-050b7715fdd1-image.png


  • Netgate Administrator

    That error shows it can't allocate space in the table to that address because there is no subnet containing it.
    As I said, check the DHCP logs. There should be an error shown when this first happened if it failed to pull an IP. Is that gateway IP really coming via DHCP? It's not a static gateway?

    Steve



  • Sorry selected the wrong screen. Yes it is DHCP 100% sure, I get a new ip on release and renew, i do not have a static IP.

    ISP Sky UK fibre via VDSL.

    The strange part is that it stops working on upgrade from 2.3 to 2.4. It does not work with a clean install of 2.4 and importing settings and it does not work doing a clean install and just applying the same settings.

    It is like something has change in 2.4 that needs a tweak to work but i cannot figure out what.

    Luckily i have a VM so i can easily roll back to 2.3 in seconds with a mouse click.

    3fd2c6d5-d364-4a73-bc1a-799b48c48bc2-image.png


  • Netgate Administrator

    Hmm, you might be hitting this: https://redmine.pfsense.org/issues/9267

    Does it continually try to pull an IP and fail?

    Is 2.127.238.131 the previous IP?

    Steve


Log in to reply