Can't change WAN Config Type (invalid IP.. PPPoE Password...)



  • I set up a computer with PFSense about a month ago. I'm now putting it into service and have run into a problem. Originally it had an earlier version of PFSense but it upgraded to 2.4.4-RELEASE-p3 (amd64).

    I initially set up the system with DHCP for the WAN. I now need to change it to Static IPv4. This should have been straightforward!
    I changed the IPv4 Configuration Type to Static IPv4, put in the two IP addresses (WAN and Gateway) and /30 mask, and clicked on Save. I get two error messages:
    An invalid IP address was detected in the 'Reject leases from' field.
    PPPoE Password and confirmed password must match!

    I've looked into this and found what should be solutions. I changed the Config Type to PPPoE, scrolled down to the Username, Password, and Confirm, and enter something in all three fields (making sure that Password and Confirm are the same).
    I hit Save and the PPPoE message is gone, but the "invalid Ip address..." is still there.
    Easy enough... I change the Type to DHCP, scroll down to "Reject leases from" and delete the "admin" that is somehow there. I hit Save, no errors! I hit Apply and all is well, but still on DHCP.
    I should note that most of the time when I do the last step, the "Reject leases from..." message goes away, but the PPPoE comes back.

    I change the Config Type to Static IPv4, type in the proper address, /30 mask, and gateway and hit Save. The two error messages come back!

    As it sits, it's still on DHCP and "admin" appears in the "reject leases from" field. I've looked at the config.xml file and find the line:
    <dhcprejectfrom></dhcprejectfrom>
    I expected to find "admin" in the middle of that.

    How should I resolve this? Would a backup/reinstall/restore be the appropriate course of action or is there something I can do remotely?

    Thanks to any in advance for useful advice.



  • Two additional comments:

    The original installation was 2.4.4.p1.

    I've considered editing the config.xml file directly. My bet is that this will fix the problem for now, but it will return if I need to edit the WAN settings again.



  • I got it resolved, but never figured out what caused the problem. I started over with an installation of p1, all went well. I configured the LAN and WAN, no issues. I restored the old configuration, no problems. I upgraded to p3 and it is working.

    I had to reconstruct a lot (VPN, Cert Authority, etc.), but that wasn't too bad.


  • LAYER 8 Moderator

    @CompProbSolv said in Can't change WAN Config Type (invalid IP.. PPPoE Password...):

    As it sits, it's still on DHCP and "admin" appears in the "reject leases from" field. I've looked at the config.xml file and find the line:
    <dhcprejectfrom></dhcprejectfrom>
    I expected to find "admin" in the middle of that.

    We had sth. quite like that on another topic. Problem was the users browser and saved credentials that somehow always got auto-inserted when he visited the WAN interface. Seems like a Chrome (not Chromium/Firefox/Opera/etc.) specific problem with its password manager running haywire on fields that have nothing to do with passwords.


Log in to reply