apcupsd



  • APC UPS



  • On a new installation of pfsense 2.4.4-RELEASE-p3 (amd64). Added pfSense package apcupsd. Unable to complete the initial General Configuration Parameters screen.

    I gave the UPS the name BR1300G, entered USB as the UPS Cable, then followed the instructions and left UPS Type field blank, and clicked Enable APC UPS Daemon service.

    When I click Save, at the bottom of the form, I am presented with this error message:

    The following input errors were detected:

    The field UPS Type is required.

    So I got clever. I type a space surrounded by quotes, like this " "

    At this point it appeared to be installed, with no error message on the General Configuration Parameters screen. However, clicking on Status, I see that I didn't really get away with it.

    Status information from apcupsd
    Running: apcaccess -h 0.0.0.0:3551

    : Bogus configuration value (invalid-ups-type)
    FATAL ERROR in apcconfig.c at line 672
    Terminating due to configuration file errors.

    I know that there are Smart UPSes and Back-UPS. My BR1300G is a Back-UPS Pro which can only connect to the controlling host using a USB cable. I am using the APC branded cable, and when it connects to the pfSense host, this message is displayed on the console screen:

    ugen2.2: <American Power Conversion Back-UPS RS 1300G FW863.L5 .D USB FWL5> at usbus2

    I would love dearly if the apcupsd package would allow me to use this UPS. Below is a screen shot of the General Configuration Parameters screen that clearly shows the instruction to leave the UPS Type field blank: "Most new UPSes are USB. A blank DEVICE setting enables autodetection, which is the best choice for most installations."

    APCUPSD_installation_error_msg.PNG



  • I had the same issue, and I typed usb into the UPS Type box and it worked (out of desparation). I know it says leave it blank, but as you discovered, that does not work as the input validation fails when you save the value. But putting usb in satisfies the validation and I think the actual apcupsd code ignores the "usb" value.



  • Wow! No kidding, thank you! Typing usb, in lowercase letters, worked perfectly. When I checked the status, it gave me a whole info dump. Beautiful!

    I appreciate your help today. 👍

    Status information from apcupsd
    Running: apcaccess -h 0.0.0.0:3551

    APC : 001,036,0879
    DATE : 2019-06-29 16:36:52 -0700
    HOSTNAME : pfSense.localdomain
    VERSION : 3.14.14 (31 May 2016) freebsd
    UPSNAME : BR1300G
    CABLE : USB Cable
    DRIVER : USB UPS Driver
    UPSMODE : Stand Alone
    STARTTIME: 2019-06-29 16:36:51 -0700
    MODEL : Back-UPS RS 1300G
    STATUS : ONLINE
    LINEV : 116.0 Volts
    LOADPCT : 10.0 Percent
    BCHARGE : 100.0 Percent
    TIMELEFT : 67.0 Minutes
    MBATTCHG : 5 Percent
    MINTIMEL : 3 Minutes
    MAXTIME : 0 Seconds
    SENSE : Medium
    LOTRANS : 88.0 Volts
    HITRANS : 147.0 Volts
    ALARMDEL : 30 Seconds
    BATTV : 26.9 Volts
    LASTXFER : No transfers since turnon
    NUMXFERS : 0
    TONBATT : 0 Seconds
    CUMONBATT: 0 Seconds
    XOFFBATT : N/A
    SELFTEST : NO
    STATFLAG : 0x05000008
    SERIALNO : 4B1402P41560
    BATTDATE : 2014-01-11
    NOMINV : 120 Volts
    NOMBATTV : 24.0 Volts
    NOMPOWER : 780 Watts
    FIRMWARE : 863.L5 .D USB FW:L5
    END APC : 2019-06-29 16:36:54 -0700


Log in to reply