WAN Disconnects Multiple Times During Use



  • Hello all,
    1st time posting, user since 2.3 with no issues. I recently upgraded my internet with spectrum to the gig service in SoCal. Ever since then I have experienced disconnects while gaming.

    Assuming it was my service provider, I had them out several times changed the modem, fix the lines and for the most part its better. What I am experiencing now which is representing the same, however ill get disconnected from the game and internet for a few minutes, internet speed drops to 80Mbps (from 800Mps) and the logs show issues on the WAN. A reboot of the modem will fix the issue but I wanted to better understand what errors the logs are indicating and see if I can address in Pfsense or if I have to go back to the service provider.

    I have been running a VPN but started a fresh install with nothing done to Pfsense and have continued to experience trouble.

    Below is system, connections is Spectum gig internet to hintron modem to pfsense system to ubiquity switch.

    Pfsesne network card Intel PRO/1000

    BIOS Vendor: American Megatrends Inc.
    Version: F2
    Release Date: Fri Feb 10 2017
    Version 2.4.4-RELEASE-p3 (amd64)
    built on Wed May 15 18:53:44 EDT 2019
    FreeBSD 11.2-RELEASE-p10

    Version information updated at Tue Jul 2 6:22:58 PDT 2019
    CPU Type Intel(R) Core(TM) i5-7500T CPU @ 2.70GHz
    4 CPUs: 1 package(s) x 4 core(s)
    AES-NI CPU Crypto: Yes (active)
    Hardware crypto AES-CBC,AES-XTS,AES-GCM,AES-ICM
    Kernel PTI Enabled

    This is from general logs

    Jul 1 20:27:40	check_reload_status		Reloading filter
    Jul 1 20:27:40	php-fpm	23062	/rc.linkup: DEVD Ethernet attached event for wan
    Jul 1 20:27:40	php-fpm	23062	/rc.linkup: HOTPLUG: Configuring interface wan
    Jul 1 20:27:40	kernel		arpresolve: can't allocate llinfo for 108.185.0.1 on em0
    Jul 1 20:27:40	kernel		arpresolve: can't allocate llinfo for 108.185.0.1 on em0
    Jul 1 20:27:40	kernel		arpresolve: can't allocate llinfo for 108.185.0.1 on em0
    Jul 1 20:27:40	kernel		arpresolve: can't allocate llinfo for 108.185.0.1 on em0
    Jul 1 20:27:40	kernel		arpresolve: can't allocate llinfo for 108.185.0.1 on em0
    Jul 1 20:27:40	kernel		arpresolve: can't allocate llinfo for 108.185.0.1 on em0
    Jul 1 20:27:40	check_reload_status		rc.newwanip starting em0
    Jul 1 20:27:40	php-fpm	23062	/rc.linkup: Gateway, none 'available' for inet6, use the first one configured. ''
    Jul 1 20:27:40	check_reload_status		Restarting ipsec tunnels
    Jul 1 20:27:41	php-fpm	19038	/rc.newwanip: Resyncing OpenVPN instances for interface WAN.
    Jul 1 20:27:41	php-fpm	19038	/rc.newwanip: Creating rrd update script
    Jul 1 20:27:41	php-fpm	22969	/rc.newwanip: rc.newwanip: Info: starting on em0.
    Jul 1 20:27:41	php-fpm	22969	/rc.newwanip: rc.newwanip: on (IP address: 108.185.3.116) (interface: WAN[wan]) (real interface: em0).
    Jul 1 20:27:42	php-fpm	22969	/rc.newwanip: Gateway, none 'available' for inet6, use the first one configured. ''
    Jul 1 20:27:43	php-fpm	19038	/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 108.185.3.116 -> 108.185.3.116 - Restarting packages.
    Jul 1 20:27:43	check_reload_status		Starting packages
    Jul 1 20:27:44	php-fpm	22969	/rc.newwanip: The command '/usr/local/sbin/unbound -c /var/unbound/unbound.conf' returned exit code '1', the output was '[1562038064] unbound[10048:0] error: bind: address already in use [1562038064] unbound[10048:0] fatal error: could not open ports'
    Jul 1 20:27:44	php-fpm	23790	/rc.start_packages: Restarting/Starting all packages.
    Jul 1 20:27:45	check_reload_status		updating dyndns wan
    Jul 1 20:27:45	check_reload_status		Reloading filter
    Jul 1 20:27:45	php-fpm	41280	/rc.linkup: DEVD Ethernet detached event for wan
    Jul 1 20:27:46	check_reload_status		Reloading filter
    Jul 1 20:27:46	php-fpm	52197	/rc.linkup: DEVD Ethernet attached event for wan
    Jul 1 20:27:46	php-fpm	52197	/rc.linkup: HOTPLUG: Configuring interface wan
    Jul 1 20:27:46	check_reload_status		rc.newwanip starting em0
    Jul 1 20:27:46	php-fpm	52197	/rc.linkup: Gateway, none 'available' for inet6, use the first one configured. ''
    Jul 1 20:27:46	check_reload_status		Restarting ipsec tunnels
    Jul 1 20:27:47	php-fpm	22969	/rc.newwanip: Resyncing OpenVPN instances for interface WAN.
    Jul 1 20:27:47	php-fpm	22969	/rc.newwanip: Creating rrd update script
    Jul 1 20:27:47	php-fpm	19038	/rc.newwanip: rc.newwanip: Info: starting on em0.
    Jul 1 20:27:47	php-fpm	19038	/rc.newwanip: rc.newwanip: on (IP address: 108.185.3.116) (interface: WAN[wan]) (real interface: em0).
    Jul 1 20:27:48	php-fpm	19038	/rc.newwanip: Gateway, none 'available' for inet6, use the first one configured. ''
    Jul 1 20:27:49	php-fpm	22969	/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 108.185.3.116 -> 108.185.3.116 - Restarting packages.
    Jul 1 20:27:49	check_reload_status		Starting packages
    Jul 1 20:27:50	php-fpm	23790	/rc.start_packages: Restarting/Starting all packages.
    Jul 1 20:27:50	check_reload_status		updating dyndns wan
    Jul 1 20:27:50	check_reload_status		Reloading filter
    Jul 1 20:27:52	php-fpm	19038	/rc.newwanip: Resyncing OpenVPN instances for interface WAN.
    Jul 1 20:27:52	php-fpm	19038	/rc.newwanip: Creating rrd update script
    Jul 1 20:27:54	php-fpm	19038	/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 108.185.3.116 -> 108.185.3.116 - Restarting packages.
    Jul 1 20:27:54	check_reload_status		Starting packages
    Jul 1 20:27:55	php-fpm	5257	/rc.start_packages: Restarting/Starting all packages.
    

    This if from gateway logs:

    Jul 1 17:59:28	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 17:59:29	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 17:59:29	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 17:59:31	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 17:59:37	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 18:30:46	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:46	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:47	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:47	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:48	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:48	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:49	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:49	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:50	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:50	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:51	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:52	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:52	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:53	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:53	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:54	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:54	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:55	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:55	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 18:30:57	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 18:31:03	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 20:22:25	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:22:25	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:22:27	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 20:22:57	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:22:57	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:22:59	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 20:27:21	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:21	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:23	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 20:27:26	dpinger		WAN_DHCP 108.185.0.1: Alarm latency 13688us stddev 6607us loss 33%
    Jul 1 20:27:29	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 20:27:30	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:31	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:31	dpinger		WAN_DHCP 108.185.0.1: Alarm latency 0us stddev 0us loss 100%
    Jul 1 20:27:31	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:32	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:32	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:33	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:33	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:34	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:34	dpinger		WAN_DHCP 108.185.0.1: sendto error: 65
    Jul 1 20:27:36	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 20:27:42	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    Jul 1 20:27:47	dpinger		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 108.185.0.1 bind_addr 108.185.3.116 identifier "WAN_DHCP "
    

  • Netgate Administrator

    What exact modem model do you have? That does seem similar to issues I've seen reported with some. Though I've yet to experience it myself.

    Steve



  • @stephenw10
    Thanks for reply. It’s a Hintron E31N2V1


  • Netgate Administrator

    @sheen73 said in WAN Disconnects Multiple Times During Use:

    Hintron E31N2V1

    Hmm, well it's not on the list specifically and 30s of Googling shows positive reviews so maybe not that.
    https://badmodems.com/Forum/app.php/badmodems
    https://www.dslreports.com/forum/r32152762-

    Steve


Log in to reply