Issue running service ntopng



  • Good afternoon, I have a problem with this ntoppng service since previously it worked without problems in version 2.4.4-RELEASE-p2 (amd64) and suddenly in that same version it stopped working.
    Reinstall the package and nothing, delete and re-install the package and nothing that runs.
    I also updated the pfsense to its latest version available 2.4.4-RELEASE-p3 discarding that it was because of the software version and nothing.
    In the logs comes the following:
    2.4.4-RELEASE-p3 (amd64)
    built on Wed May 15 18:53:44 EDT 2019
    FreeBSD 11.2-RELEASE-p10

    Jul 2 14:08:30 ntopng: [Redis.cpp:111] ERROR: ntopng requires redis server to be up and running
    Jul 2 14:08:30 ntopng: [Redis.cpp:112] ERROR: Please start it and try again or use -r
    Jul 2 14:08:30 ntopng: [Redis.cpp:113] ERROR: to specify a redis server other than the default
    Jul 2 14:09:26 php-fpm[723]: /rc.start_packages: The command '/usr/local/bin/redis-cli SET ntopng.user.admin.password '1e1af1771cd5963027594b4ee702f4c6'' returned exit code '1', the output was 'Could not connect to Redis at 127.0.0.1:6379: Operation timed out'
    Jul 2 14:10:41 php-fpm[723]: /rc.start_packages: The command '/usr/local/bin/redis-cli SET ntopng.user.admin.group administrator' returned exit code '1', the output was 'Could not connect to Redis at 127.0.0.1:6379: Operation timed out'
    Jul 2 14:11:56 php-fpm[723]: /rc.start_packages: The command '/usr/local/bin/redis-cli save' returned exit code '1', the output was 'Could not connect to Redis at 127.0.0.1:6379: Operation timed out'
    Jul 2 14:11:58 ntopng: [Redis.cpp:111] ERROR: ntopng requires redis server to be up and running
    Jul 2 14:11:58 ntopng: [Redis.cpp:112] ERROR: Please start it and try again or use -r
    Jul 2 14:11:58 ntopng: [Redis.cpp:113] ERROR: to specify a redis server other than the default
    Jul 2 14:12:17 ntopng: [Redis.cpp:111] ERROR: ntopng requires redis server to be up and running
    Jul 2 14:12:17 ntopng: [Redis.cpp:112] ERROR: Please start it and try again or use -r
    Jul 2 14:12:17 ntopng: [Redis.cpp:113] ERROR: to specify a redis server other than the default

    Help me!!
    Thanks!



  • Seeing same issue.



  • Hi also same issue here.
    Same thing that this guy : https://github.com/ntop/ntopng/issues/2429

    I think this has to do with the loopback interface, should i be able to ping 127.0.0.1 from ssh on the pfsense itself ?



  • Issue resolved for me : I remove 127.0.0.1 from General Setup / DNS Servers.
    redis and ntop are working


Log in to reply