SG-1100 Failing Re-install: No FDT Memory Address



  • Power outage during image update led to need for re-image. Every time I attempt to run usbrecovery, I get the following:

    MMC erase: dev # 1, block # 0, count 4194304 ... 4194304 blocks erased: OK
    starting USB...
    USB0: Register 2000104 NbrPorts 2
    Starting the controller
    USB XHCI 1.00
    USB1: USB EHCI 1.00
    scanning bus 0 for devices... 1 USB Device(s) found
    scanning bus 1 for devices... 2 USB Device(s) found
    scanning usb for storage devices... 1 Storage Device(s) found
    ** Unrecognized filesystem type **
    ** Invalid partition 2 **
    libfdt fdt_check_header(): FDT_ERR_BADMAGIC
    No FDT memory address configured. Please configure
    the FDT address via "fdt addr <address>" command.
    Aborting!
    No FDT memory address configured. Please configure
    the FDT address via "fdt addr <address>" command.
    Aborting!
    Starting EFI application at 05000000 ...
    WARNING: Invalid device tree, expect boot to fail
    efi_load_pe: Invalid DOS Signature
    Application terminated, r = -2]


  • Rebel Alliance Developer Netgate

    Open an issue at https://go.netgate.com and the support team can help you out.



  • Did you ever end up getting this figured out, I am having this issue currently.


  • Netgate Administrator

    If you are seeing that exact error where it shows it can see the attached USB stick:

    scanning usb for storage devices... 1 Storage Device(s) found
    

    But cannot boot from it's either the wrong image or the image is not correctly on the USB stick.

    Check the file checksum of the image to make sure it dowloaded correctly (and is the correct image).

    I recommend using Etcher to write the image to USB. It can write out the image from the compressed file directly which eliminates any issues extracting it.

    Steve


Log in to reply