Cannot see PCIE NIC , only motherboard



  • Hey everyone

    I decided to get my toes wet with some more advanced networking; I installed pfsense on a bare metal computer (AMD64) and then got it up and running. I intend to use it as a switch/vlan container for my own things separate from the main network. So the breakdown is like so:

    ISP router is connected to-->Other peoples things+MyPfsensebox(is connected to and handles my things)

    I got it working and running; but then needed more ports. picked up a HP NC375T and put it in, it lights up but I do not see it on the interfaces menu when I try and add it to pfsense, nor do I see a Available network ports: entry option

    so the software & hardware setup is as follows
    Pfsense : 2.4.4-p3
    PC: AMD A10 6800k , 10gb of ddr3 and a single Ethernet port on a OEM motherboard
    Not detecting NIC : HP NC375T

    other notable things is that when I plug things into the new NIC and try to Boot PFsense it never does; however leaving it installed and only plugging ethernet into the motherboard port allows for normal installation.

    Currently I'm just trying to get it set up before I connect it to the rest of my network so currently its just the PFsense PC-->Old wifi router-->Laptop im using to access the web GUI.

    Any assistance or ideas would be greatly appreciated.



  • @MatPat said in Cannot see PCIE NIC , only motherboard:

    normal installation

    That is : a firewall router with only one NIC is like a plane with one wing missing.

    @MatPat said in Cannot see PCIE NIC , only motherboard:

    picked up a HP NC375T

    Is this a NIC ?
    Is it recognized by FreeBSD ?

    NIC Issues => https://docs.netgate.com/pfsense/en/latest/hardware/tuning-and-troubleshooting-network-cards.html

    Also, have a look at the console : option 8 and type

    dmesg
    

    is your NIC recognized ? Any details ?
    If FreeBSD, the underlying OS of pfSense, doesn't find the NIC then it's normal that pfSense doesn't know anything about it.



  • All I see from entering that command is the defualt interface, alc0: its link state is going up and down followed by DMA write errors and it resetting. then arpresolve comes back with cant allocate llinfo for 192.168.0.1 on alc0.

    As for the link I already went through that, no luck.



  • @Gertjan said in Cannot see PCIE NIC , only motherboard:

    normal installation

    That is : a firewall router with only one NIC is like a plane with one wing missing.

    You can set up a firewall/router with 1 NIC and a VLAN.



  • @Gertjan said in Cannot see PCIE NIC , only motherboard:

    HP NC375T

    I don't see the HP NC375T ot its NetXen NX3031 chipset in the FreeBSD 11.2 HCL. https://www.freebsd.org/releases/11.2R/hardware.html#ethernet
    Bet Windows would work! :)
    a96178c3-3d10-4783-8b94-f306b87e9343-image.png



  • @MatPat said in Cannot see PCIE NIC , only motherboard:

    HP NC375T

    That nic seems to be "interesting" putting it mildly.
    BSD support- Well no as it seems (quick google). Linux - partial

    So if you really want to use that card my best suggestion would be to download and install Hyper-V server and then run PFSense as a VM ontop of that.

    Hyper-V server is a free download from MS (technically it's never expiring trial). In reality it's server core with the Hyper-V role pre-selected.



  • @Mats I do posess a copy of windows server 2019; would that be satisfactory?

    I want to run it without any montors ( headless ) and Remote desktop in if needed so I'm not sure if hyper V server allows that.



  • @MatPat There's no RDP for pfSense, but you can connect to a virtual console session through the Hyper-V Manager (or SSH).



  • @MatPat

    Server 2019 will do very nicely if you can use that license.

    As @provels said you can't RDP straight to a PFsense VM but you can use RDP for remote management of the hyper-V host and use Hyper-V manager locally on that host to manage the PFsense VM and see its console.
    for admin of Pfsense it's the usual webgui.

    The main difference with core is that you can't run hyper-V manager locally on it. You will have to do that from another windows box and set the FW and permissions right to allow it (a little messy). FiveNine made a good free hyper-v management tool that you could install locally on a core server.

    These days Microsoft have their "new" windows admin server too. It can (on paper at least be installed on core and manage hyper-v). I have to do a lab on that some day



  • yes, Im aware for PFsense, I was using the webGUI as my "remote console" but what I wanted to ask was if hyper V server has microsofts own RDP on it



  • @MatPat Yes, but you would need to install the GUI version, not Core.



  • @MatPat @provels

    Yes. Core edition has RDP on it.
    You will get a console only GUI when you connect over RDP but it most certainly has RDP support.

    I just had to do a test of Hyper-V server and windows admin center together.
    Yes they work together. Yes you can use the admin center GUI to create v-switches and VM:s
    Yes you can start and stop VM:s and you are supposed to be able to use the VM-viewer too. I couldn't test that since my test machine is from the stone-age and misses Dep so therefore I can't start a VM



  • Okay so I switched over to a copy of windows server 2019; I can see the card now in my device manager and it correctly picks it up as a network Ethernet card, however no connections work, it seems to be a driver or lack thereof.

    I downloaded the driver, the exe version that is and tried to install; it prevents me from doing so stating that the OS version is different. Tried compatibility mode, no luck.

    I went online and downloaded the zipped drivers from here : https://www.driverscloud.com/en/drivers/hardware/68945/hp-nc375t-pci-express-quad-port-gigabit-server-adapter leading me here to this driver -> https://www.driverscloud.com/en/services/GetInformationDriver/29428-26262/qlogic-qlxge-ws2012r2-5-3-25-0425-whqlzip

    It was zipped so should be fine right? no, it installed fine and the card displays in device manger with the appropriate model name; however there are still 4 devices under "other devices" that state themselves as being uninstalled Ethernet controllers. Plugging in the device the appropriate Ethernet ports light up however I cannot see it on the router IP.



  • Try this from HP's site.
    https://support.hpe.com/hpesc/public/km/product/4038768/Product#t=DriversandSoftware&sort=relevancy&layout=table&f:@kmswtargetproductenvironmentlatest=[4038768_Microsoft Windows Server 2012 R2]&f:@kmswsoftwaretypekey=[swt8000029,swt8000113]&hpe=1
    HP lists the latest driver to be for 2012 R2. May work or not. If you have the box connected to the Internet through another network card, see if you can get it to look online to Windows update. That's what I had to do to get my I340-T4 the latest driver (from 2013, no less...). Worst case, it ends up back on Ebay.



  • Upgraded my testbox to an Old I5 CPU.
    Now it can run Hyper-V so that I could test Admin center.

    It works. I'm currently installing a test PFSense over RDP! .Admincenter will give you an RDP file that connects straight to the VM so im running RDP to the console of my PFSense VM



  • @provels I havent managed to get it connected to the internet just yet, but a new network switch I picked up yesterday should be coming in tommorow. I'll hook it up and try it.

    Otherwise I did try manually downloading and installing the 2012 drivers; but as I made note of above it only displays the cards model, no luck getting it to work.

    Will try using online windows update though. I'll report back tomorrow.

    @Mats I got win server 2019 running normally now; headless. I control it with RDP over LAN.


Log in to reply