Reverse proxy issue

  • I installed pfsense 2.4.4-RELEASE-p3 (amd64). Then i added the squid package through the package manager.
    I enabled squid proxy with default local cache settings and also enabled reverse proxy with the OWA settings.
    When i try to connect from browser to the pfsense ip:reverseproxyport i receive the following error

    The requested URL could not be retrieved
    The following error was encountered while trying to retrieve the URL:

    Access Denied.

    Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

    Your cache administrator is admin@localhost.

    (see the image)

    how can this be resolved? what is the actual issue?


  • Hey! Is it WAN IP? OWA - Outlook Web Access? How about firewall rules?
    I recommend to use HAProxy instead of Squid reverse proxy.

  • Outlook Web Access. About the rules i have only one rule (from any to any).

    If i use HAProxy what settings do i have to make?

Log in to reply