SSH (Solved)



  • I enabled SSH; however, I kept getting: ssh_dispatch_run_fatal: Connection to 192.168.1.1 port 22: Operation timed out

    What's up with that when I am accessing from LAN? I selected a password or public key.



  • @NollipfSense said in SSH:

    ssh_dispatch_run_fatal

    Using what ssh client ?

    A recent Putty would connect after entering an IP and port.

    edit : Firewall rules on LAN interface do let enter the ssh traffic ?


  • LAYER 8 Global Moderator

    Unless he disabled the antilock rule, once you enable ssh its in the antilock out rule to be allowed.

    Maybe didn't actually enable it? Maybe he changed the port from 22? He is has a software firewall on the client he is running blocking it? His pfsense lan IP is not actually 192.168.1.1?

    ssh didn't actually start for some reason?

    Lots of possible reasons it could be timing out to connect.

    edit:
    I should test this - is it possible to create a floating rule that blocks the antilock out rule? Hmmm - be right back.

    edit2: Nope even putting a floating rule to block doesn't stop antilockout - which is stated on the rules order link
    https://docs.netgate.com/pfsense/en/latest/firewall/firewall-rule-processing-order.html

    Internal automatic rules (pass and block for various items like lockout, snort, DHCP, etc.)

    Are above floating even.. so seems only way you could firewall yourself from ssh on the lan would be to have disabled the antilockout.



  • It seems that the secure shell daemon not have been running for some reason...all is good now.


Log in to reply