Intermittent Connection Issues



  • I have been running pfSense in a lab/home setting for the better part of the last two years, and historically I have never had a single problem. I have AT&T U-verse service, which uses a miserable proprietary router. I have a dmz set up for pfSense (this router does not have a bridged mode), and this has worked perfectly fine for several years.

    Recently I have been having some intermittent connection issues, with some sites working perfectly all the time, others working most of the time, and some working about 50% of the time. Google.com, youtube.com, consistently work. Gmail works about 80% of the time, and the my ebay page works less than 50% of the time. Sometimes if I let the site sit loaded for 5-7 minutes, it will eventually work.

    If I connect directly to the ATT router, all is well, but once I put pfSense into the equation, issues start to appear. I tried restoring and older known-good pfSense configuration, and this did not solve the issue. I have tried taking all switches out of the equation, and this does not solve the issue either. I tried running pfSense on entirely different system to rule out hardware issues, and this didn't solve it either. I am using the google DNS servers (8.8.8.8/8.8.4.4), and switching to other DNS servers didn't help.

    Purely as a troubleshooting measure, I decided to try a different-but-similar piece of software. Strangely, what did work was installing OPNsense on another system and then "restoring" it using my known-good pfSense configuration file. This does lock me out of the system password-wise, but for some unexplained reason this worked. When I tried installing and configuring (from scratch) yet another system using OPNsense, I have exactly the same issues. I went through and tried to match all settings between the two OPNsense systems, and the problem still persists.

    This issue spans multiple clients, both mac and Windows.

    I will admit that I am not a sysadmin, though I do have some networking knowledge. That said, this one has me pretty well stumped. If anyone has an idea as to what the issue might be, I'd love to hear about it.



  • Just a guess : what are your local LAN networks ?
    Recently, 'an issue was that a local LAN had an self-made up LAN IP range, which was actually also used by many 'Google' IP's, thus breaking the access to all there servers.


  • Netgate Administrator

    Check this: https://docs.netgate.com/pfsense/en/latest/routing/unable-to-access-some-websites.html

    But I would check MTU or bad subnet/mask first.

    Steve


Log in to reply