XG-7100 1U SFP+ 10G not working



  • We have an XG-7100 1U that we can't get any SFP modules working on.

    We've tried a direct attach cable (DAC) and a 10GbE Copper Ethernet module.

    In both cases the "media:" shows as "media: Ethernet autoselect (Unknown <rxpause,txpause>)". We're connecting to a 10Gbit SFP+ port on a Ubiquiti USW 48-Port which has not had any issue connecting to other 10G devices.

    Because of another forum post I checked https://store.netgate.com/XG-7100.aspx to see that a message was added that I'm pretty sure wasn't there when we purchased our device. It says "Note: Copper SFP/SFP+ not supported.", which is even more odd because the SFP+ Cables drop-down on that same order page lists the same type of TwinAX copper cable we're trying to use to connect to the Ubiquiti switch.

    What 10G SFP+ modules are actually supported by this device? Can anyone give me a list of 10G SFP+ modules that they have confirmed working on actual hardware? We'll purchase that to eliminate any potential compatibility issues.

    Additionally we've tried connecting ix0 to ix1 with the SFP+ modules we have only to confirm the same behavior. The Ubiquiti switch recognizes both modules and shows 10,000 FDX in both cases while plugged into the XG-7100 1U.


  • LAYER 8 Netgate

    Twinax DACs will work. 10GbaseT modules will not. If you tried booting with one inserted you might have to hard power cycle to get anything recognized in that port again.

    When inserting modules after boot, you might need to kick the port into gear with one of these two sequences:

    ifconfig ixX media autoselect

    or

    ifconfig ixX down
    ifconfig ixX up

    That only applies when changing around modules after boot, so this might apply to changing DACs around.



  • @Derelict I did try that as per other suggestions in other forum posts.

    Do you have the part number of a known working Twinax DAC with the XG-7100U?
    Something I can order to eliminate any possibility that the parts I have are the issue.


  • LAYER 8 Netgate

    This is the output of an Intel-specific 10Gtek CAB-10GSFP-P1M on an XG-7100.

    I have no idea if that cable will work in the Ubiquiti switch.

    Personally, I would use an Intel-specific module on the XG-7100 and a Ubiquiti-specific module on the Ubiquiti side and a fiber patch cable. These things are dirt cheap these days from 10Gtek, FiberStore, Addon, etc. Especially multi-mode. Probably cheaper or comparable to a DAC.

    They also make DACs with different code on each side.

    ix1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	options=e400bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    	capabilities=f507bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWFILTER,VLAN_HWTSO,NETMAP,RXCSUM_IPV6,TXCSUM_IPV6>
    	ether 00:08:a2:0e:a8:62
    	hwaddr 00:08:a2:0e:a8:62
    	inet6 fe80::208:a2ff:fe0e:a862%ix1 prefixlen 64 scopeid 0x2
    	inet 192.168.200.1 netmask 0xfffffffc broadcast 192.168.200.3
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    	media: Ethernet autoselect (10Gbase-Twinax <full-duplex,rxpause,txpause>)
    	status: active
    	supported media:
    		media autoselect
    		media 10Gbase-Twinax
    	plugged: SFP/SFP+/SFP28 Unknown (Copper pigtail)
    	vendor: Intel Corp PN: 821-24-011-02 SN: INS11I50264 DATE: 2013-01-01
    
    PING 192.168.200.2 (192.168.200.2) from 192.168.200.1: 56 data bytes
    64 bytes from 192.168.200.2: icmp_seq=0 ttl=64 time=0.144 ms
    64 bytes from 192.168.200.2: icmp_seq=1 ttl=64 time=0.070 ms
    64 bytes from 192.168.200.2: icmp_seq=2 ttl=64 time=0.066 ms
    
    --- 192.168.200.2 ping statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 0.066/0.093/0.144/0.036 ms
    


  • Thank you for the information. We're purchasing the Intel variant of this module for testing.



  • @Derelict Thank you, this module worked. While it still shows "Unknown" and doesn't show vendor/module information, the connection is up and working.


Log in to reply