Adding NICs



  • I am having a problem adding extra NIC's to my pfSense system.

    I have a Supermicro motherboard with 2 NIC's, em0 & em1, that works just fine. However if I add an Intel 4 x NIC PCIe card, pfSense stops working. Everything looks OK, the new NIC's are recognized as em2 - em5 but no data comes out of any port. I have tried rebuilding pfSense from scratch (ie from a USB stick to a clean disk) but nothing works. If I remove the Intel card everything is fine, add it back in and no pfSense will not talk on any interface.

    I have two of these motherboards and another single NIC Intel card that behaves exactly the same way so I don't think it is the hardware at fault.

    What am I doing wrong?



  • What model of card do you have? FreeBSD support for Intel is usually good, but maybe you have an oddball? Any BIOS updates for the mainboard?

    https://docs.netgate.com/pfsense/en/latest/hardware/tuning-and-troubleshooting-network-cards.html#intel-igb-4-and-em-4-cards

    Maybe try increasing nmbclusters as per the tip and see if that helps.


  • LAYER 8 Netgate

    Are you sure the new NICs are being added as em2-em5 and they're not being enumerated as em0-em3 and pushing the on-board NICs to em4 - em5?

    I'd note the MAC addresses of the existing NICs then watch the boot log dmesgs and match them up.

    If that is the case you can just re-patch to the new em0 and em1 in the new locations or reassign the NICs to the new numbering as em0 and em1.



  • KOM - the card is an Intel Pro/1000 PT Quad Port and I updated the BIOS. Many thanks for your replies, I'll follow the link.

    Derelict - without the 4 x NIC card the onboard NIC's come in at em0 & em1, I just presumed they would stay there but I see what you mean, I'll try using the autodetect feature.

    Many thanks, will report back after some more trials.



  • Solved!!!!

    The new card pushed the onboard NIC's to em4 & em5, all works now.

    Just wish I'd have thought of that a few hours ago!


  • LAYER 8 Netgate

    Glad you got it sorted.


Log in to reply