Interface unexpectedly down how do I troubleshoot it



  • I have another topic posted where I explain that I have my main pfsense install on an unraid VM. My backup is on a Dell Optiplex. When I am running on my main setup, one of my interfaces unexpectedly stopped working. I upgraded the server hardware (processor and motherboard), but nothing else changed. I am able to pass through the quad port nic card. Everything works except for the Interface. I have the same setup on the Dell Optiplex, and the interface is working (but DNS isn't go figure as described in my other post). I've deleted the interface and started from scratch copying all the setting over, and there is no traffic on it. What do I need to do to troubleshoot this? Do I need to reinstall pfsense?


  • LAYER 8

    sorry maybe my english is not very good, but what do you mean with " Everything works except for the Interface" ?
    is it entirely missing from the system ? you can't surf the web? can you ping lan to lan / lan to pfsense / lan to other interfaces? what does not work exactly? VM? which one? how did you configured it ? screenshot / diagram / painting , feed us with more information ☺



  • Let me try and be a bit more clear. The WAN and LAN interfaces work. This interface, called IOT, worked for the past 6 months. All of a sudden it is not passing any traffic nor recognizing connected devices. So for example, my FireTV says no network connection. I put together a photo showing the various interfaces and it not showing traffic. I've also added my firewall rules. I don't know what caused this to change. I reset pfsense to factory default and reloaded the configuration file (which work on my backup box). pfsense setup.jpg Screen Shot 2019-07-25 at 3.21.01 PM.png



  • I tried to delete the vlan and interface and recreated it but no luck.


  • LAYER 8

    pls add a screenshot of the interface configuration
    for the moment i don't see anything strange
    the iot/switch i suppose are configured for the same vlan 10 ?



  • DE63A8D9-91CD-476E-A11C-21551BD37DAD.jpeg



  • Yes nothing changed with the switches. They are all configured on vlan 10. Like I said, this exact configuration was working a couple of days ago on this instance of pfsense. The only other thing i can think of at the moment is to make this vlan on one of my 2 available nic ports. That way its not shared with my lan port. But that still doesn’t explain why it works on another pfsense config but not on the one described here.


  • LAYER 8

    try to set the speed and duplex to autoselect. there is no need to hide private address. can you ping that 10.10.x.1 from lan?



  • So I just ended up using one of my extra ports to reconfigure the vlan on it. I deleted all the other instances and redid the firewall rules. It now works. I don't know what the issue was. It's probably cleaner to keep the vlan on it's own port and not shared with my lan port. Thanks for your replies.


Log in to reply