NAT 1:1 Polycom VSX 7000


  • LAYER 8 Netgate

    You need to look into the SIP protocol and see what it's doing.


  • Netgate Administrator

    Yes, you would need to filer additionally by port 5060 and then download and check the actual SIP packets to see what is being sent. You probably don't want to post that publicly though.

    Steve



  • What would the tcpdump command syntax look like, just to filter everything to my wan-ip port 189.20.108.XX port 5060?


  • Netgate Administrator



  • @stephenw10

    Hi Steve, how are you?
    I monitored a connection made by my videoconferencing system, using "pftop" CLI my polycom connects with the target, but "NO_TRAFFIC: SINGLE" communication errors occur.

    PR        DIR SRC                                           DEST                                                   STATE                AGE       EXP     PKTS    BYTES
    rsvp      In  192.168.40.251:0                              140.242.250.200:0                              NO_TRAFFIC:SINGLE       00:15:15  00:00:19        0        0
    tcp       In  192.168.40.251:3233                           140.242.250.200:1720                          ESTABLISHED:ESTABLISHED  00:07:57  23:58:04       15     1096
    tcp       Out 189.20.108.XX:3233                            140.242.250.200:1720                          ESTABLISHED:ESTABLISHED  00:07:57  23:58:04       15     1096
    tcp       In  192.168.40.251:3234                           140.242.250.200:3242                          ESTABLISHED:ESTABLISHED  00:07:57  23:59:35      181    10480
    tcp       Out 189.20.108.XX:3234                            140.242.250.200:3242                          ESTABLISHED:ESTABLISHED  00:07:57  23:59:35      181    10480
    udp       In  192.168.40.251:3232                           140.242.250.200:3262                           NO_TRAFFIC:SINGLE       00:07:56  00:00:30    19850 13004860
    udp       Out 189.20.108.XX:3232                            140.242.250.200:3262                               SINGLE:NO_TRAFFIC   00:07:56  00:00:30    19850 13004860
    udp       In  192.168.40.251:3231                           140.242.250.200:3261                           NO_TRAFFIC:SINGLE       00:07:51  00:00:29       95     7220
    udp       Out 189.20.108.XX:3231                            140.242.250.200:3261                               SINGLE:NO_TRAFFIC   00:07:51  00:00:29       95     7220
    udp       In  192.168.40.251:3233                           140.242.250.200:3263                           NO_TRAFFIC:SINGLE       00:07:51  00:00:29       95     9120
    udp       Out 189.20.108.XX:3233                            140.242.250.200:3263                               SINGLE:NO_TRAFFIC   00:07:51  00:00:29       95     9120
    udp       In  192.168.40.251:3235                           140.242.250.200:3265                           NO_TRAFFIC:SINGLE       00:07:51  00:00:29       95     7220
    udp       Out 189.20.108.XX:3235                            140.242.250.200:3265                               SINGLE:NO_TRAFFIC   00:07:51  00:00:29       95     7220
    udp       In  192.168.40.251:3237                           140.242.250.200:3267                           NO_TRAFFIC:SINGLE       00:07:51  00:00:29       95     7240
    udp       Out 189.20.108.XX:3237                            140.242.250.200:3267                               SINGLE:NO_TRAFFIC   00:07:51  00:00:29       95     7240
    
    

    Best regards,
    Wesley Santos


  • Netgate Administrator

    That's not necessarily an error but you would expect more traffic when it connects correctly.

    I would bet it's sending it's internal private IP still we've seen that many many times. Including numerous times when a VoIP provider told us it definitely wasn't and we had to prove it was using packet captures.

    We would need to see the SIP packets to be sure.

    PM them to me if you prefer. I'll take a look when I have time.

    Steve



  • can i send you a .pcap packet capture for you to help analyze?


  • Netgate Administrator

    Yes, start a chat and attach it there.



  • not allowed, your chat is restricted to people you follow only


  • LAYER 8 Netgate

    Post whatever it is you think is telling you that. If that is the case it should not be. People chat me all the time without following.



  • ERROR
    This user has restricted their chat messages. They must follow you before you can talk to them


  • Netgate Administrator

    Hmm, must have changed the default at a forum update or something. I've changed that setting now, try again.

    Steve



  • Your chat is now released.



  • Dear, I made the capture available on Google Drive


  • Netgate Administrator

    Great I have that.

    There are no SIP packets in there so I can't check that directly but it looks like it's still sending it's internal IP as the address to connect back to which can never work. For example:

    Selection_677.png

    And:

    Selection_678.png

    I won't to be any sort of expert in those protocols but from your description of the behaviour and the fact we see only outgoing RTP traffic in the pcap I think it is not configured to send the external IP.

    You need to set that correctly in the Polycom device before it can work behind NAT.

    Steve



  • Hi, thanks for your effort to help solve my case.
    Please can you explain if I used the filter correctly, I intended to monitor only LAN-ip traffic, using a filter for polycom IP address "192.168.40.251", when NAT requests occur, they should be caught in tcpdump using the command filter below?

    tcpdump -nvxi re0 -w capture.pcap host 192.168.40.251
    

    I captured packets from the WAN-ip interface, using a filter for WAN-ip and LAN-ip addresses, but when analyzing wireshark did not find NAT requests, I will forward the link of this packet in your chat.
    I used the command below.

    tcpdump -nvxi sk1 -w new.pcap "(host 189.20.108.XX or host 192.168.40.251)"
    

    Best regards,
    Wesley Santos


  • LAYER 8 Netgate

    It has nothing to do with the filter.

    The PBX is telling the far side to connect back to 192.168.40.251 on port 3230 for RTP.

    Obviously the far side cannot do that because that is your inside, non-routable, RFC1918 address.

    You need to tell the PBX to send your outside WAN address there instead.

    It is embedded in the SIP protocol. NAT can't translate it and there is no SIP ALG in pfSense to do it for you either.



  • Hey man, how you doing?
    I reviewed all NAT settings applied to "Polycom VSX 7000", also restored the applied settings and configured them again. I can not understand what I am configuring wrong with NAT inside the pfsense firewall, the polycom NAT settings are very simple, below are some pictures of the polycom NAT settings.

    LAN properties.
    Captura de tela de 2019-08-15 17-18-34.png

    Polycom NAT Settings.
    Captura de tela de 2019-08-15 17-18-12.png

    Captura de tela de 2019-08-15 17-17-06.png
    Best regards,
    Wesley Santos


  • LAYER 8 Netgate

    Sorry. I don't read Portuguese.


  • LAYER 8 Netgate



  • Sorry, I replaced the images using English.



  • Hello, I have this same problem reported by this person.
    I performed all the steps and was only able to connect with the other end by clearing the "NAT is H.323 compliant" check box, but only audio is transmitted between both ends, when I leave this option selected, I can't connect audio / video.

    1565900638171-captura-de-tela-de-2019-08-15-17-18-12.png

    In fact, I have come to the conclusion that my firewall is blocking requests on the H323 protocol, do you suggest some maneuver to free all traffic coming under the H323 protocol?

    Best regards,
    Wesley Santos


  • Netgate Administrator

    It's very unlikely to be blocking it unless you have added rules. Do you see blocked traffic?

    If you uncheck that and incoming audio streams then work then clearly the device is then sending the correct address for external clients to connect to.

    The lack of video could be related or it could be a missing firewall rule for whatever port that is using.

    Try getting a pcap with the audio functioning and see what other traffic is there on the WAN.

    Steve



  • Hi @stephenw10, how are you?
    I cleared the "H.323 NAT Compatible" checkbox, performed a new capture, traffic seems to occur between both ends, but only audio traffic occurs, video traffic requires Polycom-enabled H323 protocol.
    In your chat I sent a packet capture.

    Best regards,
    Wesley Santos


  • Netgate Administrator

    Hmm, not seeing anything obviously wrong in the pcap. It is now sending correct IP address for incoming connections in the packets I checked which is why RTP traffic is now coming back from the remote IP.

    I won't claim to be any sort of expert here, there could be something on there indicating why video is failing. I can't see why it wouldn't work though given the audio is sending.

    Do you see any errors reported in the Polycom? Or whatever you're connecting to?

    Did you try enabling h.460?

    Steve



  • Hi Steve, how are you?
    Seeing no problem during Polycom calls, I noticed that by selecting the "NAT is H.323 compliant:" checkbox does not connect to final destination, I will clear the H323 checkbox and select the H460 "Enable" checkbox. H. 460 "-Firewall" as shown in the image below.

    Captura de tela de 2019-08-19 16-30-25.png

    Best regards,
    Wesley Santos


Log in to reply