Dashboard reporting 100% cpu load though idle



  • Clean install of pfSense. Dashboard is reporting 100% cpu load. Any ideas?

    44258c71-240d-4b90-877a-362a610f25ad-image.png



  • Enable AES-NI CPU-based acceleration found at System, Advanced, Miscellaneous, Cryptographic Hardware.


  • Netgate Administrator

    It's not running at 100% if it's not using turbo mode (3101). Unless that's disabled.

    That shows nothing though. Run at the command line top -aSH. Let it run for 5s or so then hit Q to quit. Paste the output here.

    About the only thing that can use all CPU cycles when it would otherwise be idle is device polling but you would have to try hard to enable that.

    Steve



  • [2.4.4-RELEASE][admin@pfSense.localdomain]/root: top -aSH
    last pid: 17999; load averages: 0.12, 0.07, 0.02 up 0+00:03:10 22:01:34
    158 processes: 5 running, 134 sleeping, 19 waiting
    CPU: 0.0% user, 0.0% nice, 0.0% system, 0.0% interrupt, 100% idle
    Mem: 70M Active, 49M Inact, 182M Wired, 15M Buf, 7314M Free
    Swap: 3979M Total, 3979M Free

    PID USERNAME PRI NICE SIZE RES STATE C TIME WCPU COMMAND
    11 root 155 ki31 0K 64K CPU2 2 3:08 100.00% [idle{idle: cp
    11 root 155 ki31 0K 64K CPU1 1 3:07 100.00% [idle{idle: cp
    11 root 155 ki31 0K 64K CPU3 3 3:09 99.98% [idle{idle: cp
    11 root 155 ki31 0K 64K RUN 0 3:10 99.94% [idle{idle: cp
    12 root -60 - 0K 304K WAIT 3 0:00 0.04% [intr{swi4: cl
    11107 root 20 0 7812K 4204K CPU0 0 0:00 0.03% top -aSH
    30 root 16 - 0K 16K syncer 2 0:00 0.01% [syncer]
    19 root -16 - 0K 16K pftm 1 0:00 0.01% [pf purge]
    0 root -92 - 0K 432K - 3 0:00 0.00% [kernel{em0 qu
    90829 root 20 0 12904K 8128K select 3 0:00 0.00% sshd: admin@pt
    28824 root 20 0 6900K 2328K nanslp 1 0:00 0.00% [dpinger{dping
    66494 dhcpd 20 0 12580K 7480K select 1 0:00 0.00% /usr/local/sbi
    20 root -16 - 0K 16K - 2 0:00 0.00% [rand_harvestq
    46245 root 20 0 12400K 12520K select 2 0:00 0.00% /usr/local/sbi
    28824 root 20 0 6900K 2328K sbwait 0 0:00 0.00% [dpinger{dping
    86751 root 20 0 6400K 2556K select 1 0:00 0.00% /usr/sbin/sysl


  • Netgate Administrator

    Ok, so that's running at 100% idle. I see no problem there has it changed?

    Where exactly were you seeing 100% CPU load?

    Steve



  • I thought the "current" on "CPU Type" was the load. What is it?



  • That means that the actual clock speed is "3100".
    It's probably executing the NOP instruction at light speed.



  • So is this normal behavior?



  • Yep.



  • Okay the only reason I ask is because it sounds like the CPU is running at full load.


  • Netgate Administrator

    Try enabling powerd in Sys > Adv > Misc.

    That CPU should have Speedstep if it's configured correctly in the BIOS. That should save some power and will at least show varying clock speed. You might also get the full turbo speed. That will show as 3101MHz, the +1MHz being turbo enabled. That's actually up to 3400MHz for that CPU.

    Steve


Log in to reply