Help with for booting to safe mode ALWAYS



  • Okay, ive seen several posts about users wanting to boot to safe mode always, and it seems that no one wants to actually tell you how to force it to boot always, in the config, etc. I am looking for the command to force my pfsense to always boot to safe mode. Does anyone know the command and where to put it? I am not interesting in currently trouble shooting my boot issue because its for a lab environment. I just need someone to please help me out if possible. I have been googling around for a few hours and cant seem to find anything. If there is a duplicate post about this with the answer i am looking for i apologize in advanced, can someone link me to it?

    Thank you all for taking the time to even take a look at this.

    Thanks,

    Jright aligned paragraph


  • Netgate Administrator

    You mean single user mode? You could add boot_single="1" to /boot/loader.conf.local.

    What are you trying to work around?

    Steve



  • Not single user mode, safe mode, the option needs to be manually set in order to boot successfully, so i am looking for the command to auto boot into safe mode, so id ont have to manually do it. Right now i need that to happen, then i can trouble shoot booting. I am have a remote connected to it to edit config files and add anything needed, but i need to make sure i have this option added as if this pfsense reboots, I have no way to be there to boot it back into safe mode.


  • Netgate Administrator

    What option are you using now to boot into 'safe mode'?

    What version of pfSense are you running?

    Steve



  • Sorry for the delayed responses on this, Right now it is a manual process.

    I am currently running 2.4.4-RELEASE-p3

    Again, this is more of a short term solution until i can get back on site with the device.


  • Netgate Administrator

    Ok, but what are you actually doing to get into 'safe mode' currently?


Log in to reply