pfsense will not correctly pick up new ISP lease for IP address



  • Good Morning,

    Recently my ISP switched our IP to a 75.x.x.x IP address from a 172.x.x.x address. Well, corresponding with that new change, we happened to have gone through a blackout in our area. When the power came back on, my pfsense box did not want to pick up the new lease from the ISP, and instead kept picking up the old lease every time I went through the release/renew (and had the relinquish lease option ticked) from the status -> Interfaces section. I tried a direct connection through my home routers(which are usually behind the pfsense box), and they picked up the lease for the IP address correctly.

    I have tried restarting the box many times(as well as restarting the ISP modem), and it still wants to pick up the old 172.x.x.x IP, and consequently will not pick up any internet. Will I have to just re-install pfsense, or is there some other way to get the box to pick up the new lease? Another question, is it possible that the ISP has blacklisted the MAC address of the pfsense box, and that is why it will not pick up the new lease? I had previously set the box to renew the lease every 2 hours.



  • @themadsalvi just to add, everything was working perfectly fine before the blackout



  • @themadsalvi said in pfsense will not correctly pick up new ISP lease for IP address:

    and it still wants to pick up the old 172.x.x.x IP, and consequently will not pick up any internet.

    DHCP doesn't work like that.
    True, a client can have a preference, but that can be over ridden by the DHCP server The client can't refuse the offer of the DHCP server. (well, it culd, if the reply was totally BS).
    .
    It might be a good idea to show the DHCP-client logs.


  • Netgate Administrator

    The client can refuse offers from a particular dhcp server though which may be required here if there's a rogue server.

    Is that a 172 private IP or a 172 public IP? If there is some rogue dhcp server handing out 172 private IPs you need to find and remove it. It could be your cable modem doing it if it lost cable signal for example.

    See 'Rejevt leases from' here: https://docs.netgate.com/pfsense/en/latest/book/interfaces/ipv4-wan-types.html#dhcp

    Steve



  • @stephenw10 This is a 172.x.x.x public IP from the ISP.

    I recently saw what is the culprit. The pfsense PC had its time and date screwed up after the blackout. It thinks that it is April 2012, and this does not allow it to get a valid lease from anywhere(even from a router that is temporarily placed upstream from it). Since it is unable to get an outside network connection, I cannot use the ntp servers to correct the date and time. Is there a manual way to correct the date and time of the machine, just long enough for it to be able to grab a network connection, and update through ntp?



  • @themadsalvi said in pfsense will not correctly pick up new ISP lease for IP address:

    Is there a manual way to correct the date and time of the machine, just long enough for it to be able to grab a network connection, and update through ntp?

    Do your mom board settings have a way to change the date & time?


  • LAYER 8

    from console

    date yymmddhhmm
    

    example

    [2.5.0-DEVELOPMENT][root@pfSense.localdomain]/root: date 1907292244
    date: can't reach time daemon, time set locally
    Mon Jul 29 22:44:00 CEST 2019
    
    

  • Netgate Administrator

    Yup, use 'date' command at Diag > Command prompt:

    date 201907292211

    Steve



  • @kiokoman @stephenw10 , and everyone else. Thank you. That manual command allowed me to change the date and time, which in turn allowed the correct lease to be picked up. Internet is going well on all fronts.


Log in to reply