Mobile phone



  • Hi,
    I've set up OpenVPN on my Netgate 3100 and it's working fine. I set up static mapping in DHCP server for my computer and my mobile phone, see attached image. DHCP mapping.png

    Then I created aliases for all units going to my vpn, see below:
    Aliases.png

    My computer connects through vpn but not my mobile, is there another setting for mobile or what's wrong?



  • Probably something on your mobile config. OpenVPN isn't doing anything differently based on your client. Your client must conform to the OpenVPN spec and then it can connect and communicate.



  • Thanks for your answer! I connected to pfsense with OpenVPN connect with the export file. When I check on ipleak.net my public IP is shown but also the ip for my VPN provider, see attached images below. How do I force all traffic through the VPN tunnel?

    Screenshot_20190801-200226_Firefox.jpg
    Screenshot_20190801-200236_Firefox.jpg



  • It looks like it's working. DNS leaks and LAN IP leaks via WebRTC are another different problem. WebRTC is a browser thing that you can disable, . DNS leaks are usually a client issue as well, I believe. I don't have much experience with OpenVPN on Android as I've only set it up once and connected once to test it, and that was a few years ago.



  • When I visit ipleak.net on my computer I get 85.... as my public ip. My vpn-provider has a test to see if I'm connected and I get a green light on my computer but not on my android so something is wrong.



  • If they're anything like my provider (Mullvad), they have a multi-part test. Just because you got a red doesn't mean the whole thing isn't working, just that one test failed. DNS leak and WebRTC leak will get you a red on 2 of Mullvad's 4 tests. I don't believe that this is a pfSense issue now. Do some research into Android, OpenVPN and DNS leaks.



  • Thanks a lot for your help, I dig into this!


Log in to reply