Pfsense 1.2.2 on alix board



  • hi guys

    ive recently tried installing pfsense on my alix board:

    • used physdiskwrite to write the pfsense image onto a 1gig cf (winxp over a usb cardreader)
    • i then connected everything to my alix board
    • next would come the terminal part, where i did all the same like when i installed the wrap board -> but nothing shows in terraterm
    • as my alix board has an agp connection i connected a display and found a message saying "unknown flash type"

    does someone have a clue how to get pfsense going? ^^

    thank you!



  • Since I can't find anything about an ALIX board with AGP connector (slot?) I presume you mean a ALIX.1C or ALIX.1D or ALIX.3D3 board with a VGA connector.

    Correct?

    It looks as if the ALIX boards with VGA connector have AWARD BIOS. This BIOS commonly communicates via the keyboard and VGA port rather than a serial port.



  • alix 3d3 correct.

    ok that might be a reason why i dont get anything in the terminal  ;D

    but as mentioned i tried connecting the screen etc and found the mentioned error :(
    i also tried resetting the bios to default settings -> no success
    any ideas?



  • I don't have any Alix boards but this is what I would do if I had this problem.

    1. Get the exact text of the error message.

    2. Google that text. If you get more than a hundred or so hits add some additional words (e.g. Alix, FreeBSD, the brand name of your compact flash card, brand and model of your CF, etc) to the search, one additional word/phrase at a time until you get a more manageable number of hits.

    3. look up the Alix web pages and linked documentation (http://www.pcengines.ch) to see what (if anything) they say about the CF cards that can be used with your board.

    4. Report the error text to Alix technical support (if any) and ask for an explanation.

    I suspect that the message may be coming from the Alix BIOS but it may be coming from the early boot code in FreeBSD. If you haven't already tried pFsense 1.2.3 you should do so. 1.2.3 is not likely to behave any differently to an earlier version if the message is coming from the BIOS but it may behave differently if the message is coming from the FreeBSD early boot software. See http://blog.pfsense.org/?p=377 for more information on pfSense 1.2.3.



  • unfortunately google couldnt help =(
    i tried updating the bios according to an info on the pcengines website - didnt help though

    ok i tried 1.2.3 - 1st the .iso and then the .img (version from the 1st of april)

    i guess ill give the support a note…

    i shall post a reply again with what happened ;-)

    thank you so far



  • äähm… where and/or how do i contact alix support  ??? :-\



  • Where did you purchase the unit? You might want to try the reseller. First, I would try and narrow it down a bit though. Can you swap the cf card into something else, or take a cf card that is known working in another box and try that in the Alix?



  • i purchased the alix box at pcengines.ch

    and ive tried 2 different cf cards where 1 was previously running with backtrack linux and the other cf is new
    ah and i used the new one to do the bios upgrade (with a dos image on the cf that worked)


Log in to reply