How do i configure limiters on a Multi-Wan Setup

  • Hello, so i have two Wan connections from Two different ISP's a 30Mbps and a 20Mbps connection. I already configured load-balancing on the pfsense box but need help on creating limiters that would apply to both on Lan interface since i want to limit some Ip addresses to a certain bandwidth although using both connections.I have read on that topic on the pfsense webpage but i did not understand, kindly explain

  • It seems to me like there is no way to do it, as the limiters don't know anything about the WAN link that will be used (if any). They just limit the traffic you specify in the rules to a determined value.

    It would be great if the limiters could be tied to a particular gateway, so they are used only if that's the gateway that the packet goes thru after failover or load balancing. But i doubt that's possible.

    Or, at least for failover, it would be great if there was some kind of check to "ignore a firewall rule if a gateway is down". That way, you could at least create two or more rules with different gateways, so that the first rule would be configured for the preferred gateway and all of the rules could have different limiters, so no problems at all for failover with limiters. Would increase the number of rules, but at least seems doable (if pf has this option, or can be added).

  • I found an option in System - Advanced - Miscellaneous that maybe can allow this to work, it's:

    Skip rules when gateway is down
    Do not create rules when gateway is down. By default, when a rule has a gateway specified and this gateway is down, the rule is created omitting the gateway. This option overrides that behavior by omitting the entire rule instead.

    So, if the rule is omitted when the gateway is down, you could have two rules that do the same, but with different gateway and different limiters (according to the link's speed).

    However, that would be failover, not load balancing.

    If you use this, test it throughly, to see exactly what happens. From the option's description it looks like only rules with explicitly chosen gateway would be affected.

  • Hello All,

    Somebody has found a solution ?

    Another topic is near this one .
    I tested exactly what you 're speaking about wihout any success !!


Log in to reply