PfSense 2.4.4 to 2.4.4_3 update failed, OpenVPN auth-user-pass-verify fails



  • Hello all, yesterday I did a update to our production firewall and it failed bad. Almost all php5.6 to php7.2 failed. It hang several times on boot and eventually started but now OpenVPN auth-user-pass-verify via-env fails. I have a script that auth our users agains oauth2 of google. Now it fails. On the the GUI it says latest version, everything seems okay for now. Triggering update again will it fix the issue or my best solution is installing it from scratch and restoring using config file ?
    I attach a log upgrade_log.latest.txt

    Regards



  • Tons of php errors are normal for that upgrade and the release notes warn you to expect those.

    https://docs.netgate.com/pfsense/en/latest/install/upgrade-guide.html

    If you're convinced that it's somehow badly broken, then install fresh and restore your config.xml.

    No idea about your custom auth script.


Log in to reply