Internett traffic stop after a while (reboot solve it for a while)



  • Hi,

    I have installed pfsense on a new hardware ODROID-H2

    The box is working great for maybe up to 30 minutes and then the internett stop working.
    When I come home from work today I tired to access the web GUI, and it popups, but when I try to logon it will not logon... so I restarted the box from the console/terminal (physical with keyboard), and then it start working again... after a while the internett stopped worked again... and I was able to logon the Web GUI and restarted pfsense from there... and then it start working again...

    I have not intalled any package, only running with default installation the only thing I have done is disable the DNS resolver and enabled DNS forwarder and port fortwared som ports...

    I have tried to find the problems from logs....

    I have found these:
    Oct 8 17:27:54 dpinger WAN_DHCP 92.221.80.1: sendto error: 64

    It comes each second, can that be the issue ?

    It`s the gateway adress on the WAN, ISP have disabled ICMP?, maybe the ISP is blocking me for flooding?

    I will see If I can switch of these...

    Thank you all.



  • @gordon said in Internett traffic stop after a while (reboot solve it for a while):

    Don`t know what IP adress these is, maybe a DNS server?

    It's your WAN IP address assigned by your ISP's DHCP server as the label besides it says.

    Try disabling gateway monitoring via System - Routing - Gateways. Edit your default gateway. Check Gateway Action - Disable Gateway Monitoring Action and see if that alone helps. If not, disable monitoring altogether and then try again.



  • Yes the WAN IP is assigned by the ISP DHCP server.

    I figure out I was to quick... because the ping error was only before the WAN have recived IP adress (during boot up), so that cannot be the problem with the internett is freezing....

    What shall I check next time it`s freeze up ?



  • The internett stopped working again... I tried to ping the ISP GW from a computer on the LAN, noe replay...

    I tried to disable WAN network and then enable again, and then the internett started working again...

    Next time will I try to ping from the pfsense GUI and see if I got replay.... hopefully will the test isolate it to the WAN network card... driver issue ?



  • Well, you could try the two things I suggested that you try. I didn't type them out for nothing ☺



  • @KOM said in Internett traffic stop after a while (reboot solve it for a while):

    Well, you could try the two things I suggested that you try. I didn't type them out for nothing ☺

    Sorry it was not to be cocky... I belived it was not point trying since I was mistake when it comes tot he ping error... I will try one thing at the time from the suggestion from you.



  • Dpinger is what does the gateway monitoring. If it is having a problem for whatever reason, then the system will believe that your WAN is going up & down like a piston and take action accordingly.



  • @KOM I understand,

    I have not had any have problem after I disabled "Disable Gateway Monitoring Action".
    Thinks looking good, waith and see some hours... and see if its stable...

    Need to investigate further? I only have one GW so, I don't have any benefits detect if it's down or not?



  • Even with only one gateway, which is the norm, it tells you how stable your link is. You would use that knowledge when trying to troubleshoot a problem you might be having.



  • @KOM said in Internett traffic stop after a while (reboot solve it for a while):

    Even with only one gateway, which is the norm, it tells you how stable your link is. You would use that knowledge when trying to troubleshoot a problem you might be having.

    Do think its the ISP who make problems for me since I`m pining it 1 time per second?
    Or is it something else ?



  • I have no idea. I have seen a small minority of people over the years here whose Internet connections or ISPs have a problem with dpinger and it makes their connections flap like shutters on a windy day. The vast majority have no issues. I've been using pfSense for 6+ years over many different releases and I've never had an issue.



  • The issue was coming back so now have I tested to have "Gateway Monitoring" disabled and not "Gateway Action" and the problem have been present.

    Before I try to disable both, have I tried to set the WAN card to 100mbit instead of 1000mbit, and the problem have now accour.... ("Gateway Monitoring" and "Gateway Action" is not disabled), but the problem was coming back.

    Have now tried to disable both "Gateway Monitoring" and "Gateway Action", cross my fingers :)

    See screenshoot, confirm the GW to be detected down...



  • FYI, this box does have Realtek RTL8111G NICs in it...

    Screen Shot 2019-08-08 at 2.50.15 PM.png

    Jeff



  • I don't really have anything else to add other than that you can upload images here directly without having to link to some hosting site like Imgur. Just use the Upload Image button in the Edit bar when you're making a comment.


Log in to reply