Watchdog timeouts when viewing rrd graphs page - 1.2.3 embedded



  • Hi, I'm new to pfsense but I've been running into a very specific problem that I can't seem to find the solution to.  A coworker gave me a watchguard firebox x500 with pfsense embedded on it.  I configured it as needed with 1.2 on it and noticed that sometimes when I go to the rrd graphs page, I'd get part of the html output and then it would hang for about 30 seconds.  The log shows:

    kernel: re1: watchdog timeout

    In that time, no traffic is passed on the interface yet on the console the machine seems to be running fine.  I've talked with some members of the forum and I've tried the following:

    Do a fresh install of 1.2.3-RC1 embedded
    hint.acpi.0.disabled="1" in loader.conf and in devices.hints
    Change to the "Full" install kernel (SMP Support)

    The only thing I haven't tried is to disable the "pnp" support in the bios, of course its hard without a keyboard port on board.  I will try making a cable tonight I suppose.

    The HTML that does get written back to the browser always ends in the same spot:

    *   [LCDproc](/pkg_edit.php?xml=lcdproc.xml&id=0 )
    
    					*   VPN
    
        *   [IPsec](/vpn_ipsec.php)
    
        *   [OpenVPN](/pkg.php?xml=openvpn.xml)
    
        *   [PPTP](/vpn_pptp.php)
    
    					*   Status
    
    


  • Well here is probably the missing piece to the puzzle:

    I noticed that my lovely cisco vpn client changed my mtu to 1300 on all of my interfaces.  I also noticed that it only seemed to happen from my laptop and not from any other system or when I was vpn'ed home over the wan.  When I changed it to 1500 all was well, the second I change it to 1300 it causes the watchdog issue when viewing the rrd page almost 100% of the time… not sure why that would be but at least now I know how to avoid it!

    fyi changing mtu in xp/vista:
    netsh
    interface ip
    show interface

    Idx  Met  MTU  State        Name
    ---  ---  -----  -----------  -------------------
      1  50 4294967295  connected    Loopback Pseudo-Interface 1
    12  25  1500  connected    Wireless Network Connection
    13  10  1500  disconnected  Local Area Connection

    set interface 12 mtu=1500

    re1 (the lan interface) shows of having a 1500 mtu as one would expect:

    re1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500

    for now at least I know how to avoid it... thanks  ;D</up,broadcast,running,simplex,multicast>



  • This problem may be solved, but we need testers.

    Please see http://forum.pfsense.org/index.php/topic,15669.0.html


Log in to reply