Help with my PIA OpenVPN setup



  • Hello Everybody (and apologies in advance if I am posting in the wrong place),

    I currently am using pfsense as a virtual router for an esxi environment.

    I currently have three interfaces attached to the pfsense VM. One that is WAN, One that is my Main LAN, and one that I want to be a secondary LAN that routes all traffic through Private internet access via Open VPN with a kill switch should the VPN go down.

    I can't seem to get it right though. Either everything goes through the VPN or I don't have internet access, and until I get it working I won't start trying to configure the kill switch part.

    Any help anyone can give me would be greatly appreciated. I am happy to provide any details about my config anyone might need to point me in the right direction.

    Again thanks in advance,
    Tiff


  • Galactic Empire

    Enable Don't pull routes in OpenVPN.



  • Here are screen caps of all my settings I am not sure what you are recommending I change.

    sysinfo1.PNG
    sysinfo2.PNG
    system.PNG
    interfaces.jpg
    dns.PNG
    interface assignments.PNG
    ![interfacewan1.PNG](/assets/upinterfacewan2.jpg loads/files/1565551542468-interfacewan1.png)
    interfacewan2.jpg
    interfacemainlan1.PNG
    interfacemainlan2.PNG
    interfacepialan1.PNG
    interfacepialan2.PNG
    portforward.PNG
    outbound nat1.PNG
    outbound nat2.PNG
    vpn clients.PNG


  • Galactic Empire

    In the OpenVPN client settings:-

    Screenshot 2019-08-11 at 20.35.04.png

    I bet if you were to look at Diagnostics -> Routes the default route is pointing to the VPN


Log in to reply