[SOLVED] Wireless card makes computer fail on opt1 loading

  • Hello,
            I recently bought the netgear wpn311, after a suggestion on your forum.  I then plugged it in to my working pfsense box (Which is plugged in straight to the dsl modem), and saw the card after I added another interface in pfsense and it recognized my card and set it as OPT1.  I then began following this tutorial, which was recommended on the pfsense wiki (http://doc.pfsense.org/smiller/Add_WiFi_Interface.htm).  It was configuring well until I went to save the changes for the wireless preferences.  After it saved the system rebooted (I didn't make it reboot, and started displaying messages about blocks which it had never displayed before on startup).  It would then get to the part in the startup when it would try to load OPT1, then would reboot again in a continuous cycle.  The only way I could get it back to routing the ethernet correctly was by taking out the card.  I think the setup would work if I could get to the next part in the setup which is configuring the dhcp server for the wireless, but it reboots before that.

    More info:

    Netgear wpn311 Rangemax Wireless PCI Adapter
    Tried running it in Wireless G and Wireless G Turbo options (Both of which didn't work) (Haven't Tried Wireless B yet)
    Tried setting it up as subnet, my lan is on
    Pretty much followed the tutorial exactly except for the subnet
    Tried with both WPA and no encryption


  • I fuigured out how to fix this problem with the netgear wpn311 v3.  The first thing I did was to not follow that wink tutorial completely on how to setup wifi in the pfsense documentation.  The first thing I did in the opt1 settings was changing it to bridge with LAN (probably isn't necessary, need more time to experiment to get the best install) clicked the option to only allow wireless g.  After that I setup the dhcp server for opt1 which I am not sure was needed because it was being bridged with LAN.  The most important step though, was upgrading to the latest version of pfsense (I think this was 2.0 alpha).  After upgrading your system will reboot and then you go into the upgrade menu again and upgrade freebsd to the latest version.  You wpn311 v3 should now work!  I am going to post a full tutorial later with pictures and more description.

    Some things I would like to get a response on:

    How stable is the alpha version on a scale of 1 to 10 of pfsense
    How long (ballpark) will it take for the 2.0 alpha to become a official release

  • Last time I noticed pfSense 2.0 was based on FreeBSD 7.0 while pfSense 1.2.3 is based on FreeBSD 7.1. Have you tried pfSense 1.2.3? (see http://blog.pfsense.org/?p=377 for more information on pfSense 1.2.3 including a download link)

  • Yes, I have.  Is it just the pfsense release that is adding more support for atheros chipsets?  I might try going back to 1.2.3 again and trying it more, but it kept getting a hal 12 error.  Does anyone know how to fix this on the current 1.2.3 release?

  • Rebel Alliance Developer Netgate

    pfSense 2.0 is being migrated to FreeBSD 8.0 right now, there is a possibility that it might be released shortly following the drop of FreeBSD 8.0-RELEASE (but don't quote me on that, it's just what I've heard mentioned).

    Currently that is slated for August, but if recent past releases of FreeBSD have taught us anything, it's that they tend to be conservative and wait until things are really and truly ready for release before unleashing them.

  • Does the Alpha still use the atheros driver?

    I found this:

    Revision v3 of the Netgear WG311 is based on a Marvell Libertas 88W8335
         and is not supported by this driver.

    Looks like we might need the Malo driver which is in Freebsd 8.0