Cant see other computers on network



  • Ok so I went with the "Using a router as a smart switch" suggested in the Howto documentation.

    I am using my router as a smart switch with dhcp turned off and all computers including the PFS box connected to the LAN ports on the router. Nothing is plugged into the WAN port. Its working great and I am seeing a dramatic speed improvement. The only problem is none of the computers can see each other on the network now. PFS is handling all DHCP request. Any suggestions?



  • Anyone?



  • Your description is confusing.
    Can you provide a diagram?
    Are you using pfSense as a smart-switch?



  • Sorry about that, I am barely coming out of my PFS infant stages :)

    Internet–---->PFS 1.2.3 Box -------> Wireless Router ------>Internal Network (4 Computers running various operating systems that can
                          (DHCP)                (DHCP OFF/Just a Switch)                          Normally see each other)

    Ever since I turned DHCP off on the router/switch the computers have not been able to see each other. Although http performance improved dramatically. All firewalls are turned off on the router/switch. Is there something I am over looking?

    Thanks



  • See each other? What do you mean can you be more specifc? If the computers show up in the dhcp lease status, please try these IP's and hostnames to contact the other machines.
    Maybe the firewall on each machine is blocking the new subnet?



  • All of the machines show up on pfsense with a dhcp lease.

    As far as seeing each other, Example on my WindowsXP box I could normally goto network neighborhood and see all the computers connected to my network. In GNOME I would be able to click the Network tab and see all computers connected to the network. Well now nothing shows up. Its as if each computer is on its own little network.



  • 2 things

    are they all on the same subnet

    did you set your domain in pfsense and all your computers the same (windows xp will not see networked computers on other domains unless you MANUALLY set them up)


Log in to reply