• I`m using  1.2.3-RC1  pfsense version, have tried several updates, but every time i start ntop it shuts down in a matter of seconds, any idea what could be causing this?

  • this is also happing with v 1.2.2 after a few hours!!
    Don't know how to fix this :(, maybe a cron job?

    after a few seconds:have you set lan and an passord under ntop settings?

  • Having the same problem with nTop on my PFSense router.

    Running PFSense 1.2.2, and nTop version 3.3.8

    I've not tested it fully, but it seems to crash when the net throughput is at its highest (torrenting something at the moment so that killed it). I do have it monitoring the LAN port though, so it may be too much for it to handle.

    Its running on a VIA C3 1.33GHz, with 768mb RAM, 5Gigabit ethernet ports, connected to a gigabit network, with a 20mb broadband connection with a 512k up. The network is sustaining about 8 computers, with at least 3 on constantly. Medium to high net usage. I've configured the Ethernet card that its capturing, and the password, but it keeps crashing out on me.

  • seems to crash for alot of people.

    My system is a 1.8 P4 with 1.5gb ram. Crashes after a few mins, even with little to no traffic

  • mine only crashes with p2p traffic…it's really not stable yet and i've never had any luck with any of those programs....

  • On last friday, I uninstalled bandwidthd and darkstat and updated pfsense and since that it works flawlessly.

  • i'm about to try ntop again…i haven't tried it in awhile.
    i just got squid and snort working how i want...if i can get ntop working as well i'll have everything that is currently possible working on my system the way i want

    (i'd like to have havp and squid working together transparently but i don't think that's possible yet)

  • i'm still having trouble with ntop stopping….i have no idea what's causing it but it's annoying

  • @wonslung:

    i'm still having trouble with ntop stopping….i have no idea what's causing it but it's annoying

    You can change a few settings,maybe that will work?

    I have added an cron job (start ntop every hour, it only crashes here after a few hours), so it does always work :)
    line:  */60                  root  /usr/local/bin/ntop

  • does ntop only start if it's not already running?
    i wish we could figure out why it's so unstable that it NEEDS to be constantly restarted

  • wow great! i have set mine to every 20m

    I have it set to this, is this correct?

    */20                root  /usr/local/bin/ntop

    Do i need a " * " in the hour,mday, ect. boxes? I only have the minutes box filled.

    I was researching for a way to do this, i messed around with cron, (since i am not a bsd user i had a hard time) I am glad somone added the cron package what a lifesaver.

  • 0,20,40,60 * * * *

    would be the correct way to start an every 20 minute setup i think