PFSense Single user mode



  • Good Afternoon all,

    Apologies if this post is in the wrong place. Ever since I upgraded my PfSense NetGate MBT-4220 yesterday from 2.4.4 release p1 to p3, my box does not boot properly. Based on numerous posts I saw, the instructions are to boot into single user mode. When I do this, I am to type /sbin/fsck -y/ at the # prompt. When I do this, it just returns a # at the next line, not acknowledging my command entry. When I try and boot normally the system hangs on:

    #random: unblocking device.

    I've tried playing around and also received a message /etc/rc cannot create /dev/null operation not supported.

    One of the messages also indicated that the file system is in read only mode.

    I downloaded a NetGate ADI image of the most recent version and used etcher to make a bootable USB drive. I put the usb flash storage drive into the bottom USB port (USB 3.0), but it doesn't load.

    Any thoughts anyone?


  • LAYER 8

    did you try the usb 2.0 ? maybe it's the wrong image ? did you try this ? -> https://nyifiles.pfsense.org/mirror/downloads/pfSense-CE-memstick-2.4.4-RELEASE-p3-amd64.img.gz

    surely something went really wrong during the update



  • Yep I tried that. Something seems to be going on where it isnt letting me in the boot menu anymore. I dont remember if it was F2 or Esc that I was hitting as the system was booting up to get the boot menu, but now neither works.

    I was able to get a NetGate rep to help, he pointed me here:

    https://atxfiles.pfsense.org/mirror/downloads/pfSense-CE-memstick-2.4.4-RELEASE-p3-amd64.img.gz

    I tried both images and neither worked. Etcher said that the burn was successful. I bought two new USB drives from MicroCenter and tried it on both with the same result.

    Support told me to potentially replace the disk. It is an SSD M2 2242 form factor. I tried looking again at MicroCenter. They only have the 2280 form factor which I am told is too big to fit on the board.

    Do you think that the board itself is hosed? I bought the box new in December 2018 from the NetGate website.

    The box seems to be hosed.



  • I didnt address the other question. Yes, I also tried the USB 2.0 port. Same thing.

    After it tries to boot, it just hangs at random: unblocking device.


  • LAYER 8

    sometimes is F8 to change boot order
    no i don't think, right now it seems to me a software problem
    but it could be the SSD if it only go in read only mode
    i see that it support also ubuntu, you can try maybe a live iso of ubuntu and see what happen



  • @kiokoman

    I opened a ticket. My thought is to take the disk out, put it in an enclosure and wipe it formatting to FAT 32. Its not something that is supported. I suppose changing the disk to something else would have the same effect. I suspect the issue is software as well.

    The only option they are providing me is to talk to Sales for a replacement (at a cost to me since it is out of their 90-day return policy).

    I just tried the F8 option as well (I remember that from the good old Windows 95/98 days).



  • I was able to figure out my issue and get it fixed. I'm not sure what did it (or if it was a combination of all of these).

    1. I used a different computer to 'etch' my usb drive. I copied the .img file from one computer to another via a USB flash drive. I used that second computer to image my other flash drive.

    2. With the NetGate box opened, I found a switch on there (its towards the back where it says the power is supposed to be). You might have to get the timing right, but if you hold it in for a short period of time the box will reset and will let you get into your boot menu. In this case, I wanted to go into the BIOS. In my case, I had it hooked up to a TV for my display. Once the no video screensaver stopped, I let go of the power button (before the system shut down).

    3. Once in the BIOS, I saw the option to boot from the USB drive. I navigated to that with my cursor and hit enter on it and allowed the device to reboot.

    4. Once the system came back, it brought me to the pfSense installer. At this point, I wiped my machine and started fresh. Instead of using a UFS file system, I decided to use ZFS, as others have recommended that.

    5. I reloaded the configuration items from my last backup.

    Reimaging your device isn't for everyone. In my case, I was desperate and needed to get internet back at home (my phone or JetPack is a good short term solution; maybe two or so days at most).

    This beats me from having to either buy a new SSD, refresh the appliance with a fresh one, or build a computer to run this for me. Personally, I like the computer part, but it is superly overkill for a home setup. The PC I was looking at replacing this appliance with has a decent CPU, 64GB RAM, 500GB SSD drive. My current appliance has far fewer resources and it fits my needs just fine (at least for now).

    I'm still concerned about the upgrade. Needless to say, I wont be upgrading again unless I have a backout plan (I work in IT so I know better, but I don't have spare NetGate appliances laying around or old computer I could use.


  • LAYER 8

    yes ! good work, Luckily it was only a software problem


Log in to reply