Pfsense blocking plex remote acess



  • Looked through whats been posted and its either out of date or goes all over the place.

    For some reason pfsense is blocking remote access to my plex server.

    I added a port forward for the correct ip and port but this doesn't seem to have any effect.

    Beginning to wonder if i am missing something or pfblocker is block remote access for some reason.

    Any thoughts?



  • How are you testing, from WAN side or LAN? Show a screenshot of your NAT rule details. If you suspect pfB, why not disable it and test again?



  • @KOM

    Wan side

    I did turn off pfblocker after posting to no effect.

    fdsffdfsffdfsd.jpg



  • Your rule looks good. I would do a packet capture on WAN (Diagnostics - Packet Capture) and see if the traffic is hitting the WAN at all. Filter the capture for just that port to block out any noise.

    Also check your firewall log to make sure other ports it may be asking for aren't being blocked. You're sure it's only 32400?

    OK I just checked and 32400 is the default, but only tcp required so you sure change your rule to reflect that.

    https://support.plex.tv/articles/200931138-troubleshooting-remote-access/



  • @KOM said in Pfsense blocking plex remote acess:

    32400

    Missed the tcp only its changed now.

    Firewall showing nothing in regards to plex.

    Running diagnostic now.

    There also a possibility that this may be on plex side of things have to wait and see on that end.



  • If the traffic from your remote client isn't hitting your WAN then the problem is upstream somewhere.


  • LAYER 8 Global Moderator

    If you allow tcp/udp - tcp would still work.. You need to follow the troubleshooting guide
    https://docs.netgate.com/pfsense/en/latest/nat/port-forward-troubleshooting.html

    To be honest the first test you should do is, go to can you see me . org, and test for port 32400

    Does it work?
    If not sniff on wan when you run the test, do you see traffic to you on port 32400.. If not then nothing pfsense can forward, since nothing gets to pfsense.

    This really should be step one - since if traffic never gets to you, nothing you do can make it work..

    packetcapture.png

    Mine doesn't show open, because I currently run plex behind cloudflare over 443 and using ha proxy, so I can also use 443 for openvpn.

    But as you can see via the packet capture it works, and simple to just enable the forward and then it works.
    32400.png



  • @johnpoz said in Pfsense blocking plex remote acess:

    32400

    That's the crazy thing it does succeed .

    Funny thing is is a disable it and enable it it shows as succeeding then fails.



  • Probably going to do a full reset of pfsense and avoid ip6 for now as it seems the provider not got things fully working and it may be causing some flaky issues.

    Not the end of the world end i was planning to do it anyway now that the box is moved to the rack.



  • And now its working fine even though its says its not?!!


  • LAYER 8 Global Moderator

    You mean that little test thing in plex?

    This shows red?
    this.png

    You notice mine isn't even enabled - doesn't mean anything ;)

    Notice the part where is say "MAY NEED TOO" - when your doing it via cloudflare reverse, you really on purpose do not enable this because then it hands out your IP, etc. Which you don't want because you want it going through your cloudflare reverse proxy.


Log in to reply