Succesfull install on a MSI K9A2GM -F V3 mobo



  • I'm succesfully running pfSense on this motherboard.
    I've only added an Encore ENL832-TX-RE NIC (reatek 8139C based), and disabled the onboard audio chip. Integrated NIC is working out of the box (Realtek RTL 8111C).
    It's running with an Athlon 64 and 2GB of RAM.

    Hope it helps someone shopping for boards!

    Here's the dmesg of this box:

    cat dmesg.boot

    Copyright © 1992-2008 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.0-RELEASE-p8 #0: Thu Jan  8 22:07:30 EST 2009
        sullrich@freebsd7-releng_1_2_1.pfsense.org:/usr/obj.pfSense/usr/src/sys/pfSense.7
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: AMD Athlon(tm) Processor LE-1640 (2700.11-MHz 686-class CPU)
      Origin = "AuthenticAMD"  Id = 0x70ff2  Stepping = 2
      Features=0x78bfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,mmx,fxsr,sse,sse2>Features2=0x2001 <sse3,cx16>AMD Features=0xea500800 <syscall,nx,mmx+,ffxsr,rdtscp,lm,3dnow!+,3dnow!>AMD Features2=0x11d <lahf,svm,extapic,cr8,prefetch>real memory  = 2079981568 (1983 MB)
    avail memory = 2025467904 (1931 MB)
    ACPI APIC Table: <7302MS A7302200>
    ioapic0 <version 2.1="">irqs 0-23 on motherboard
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    hptrr: HPT RocketRAID controller driver v1.1 (Jan  8 2009 22:07:11)
    cryptosoft0: <software crypto="">on motherboard
    acpi0: <7302MS A7302200> on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    acpi0: reservation of ffb80000, 80000 (3) failed
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, 7bf00000 (3) failed
    Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
    acpi_timer0: <32-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
    cpu0: <acpi cpu="">on acpi0
    powernow0: <powernow! k8="">on cpu0
    device_attach: powernow0 attach returned 6
    acpi_throttle0: <acpi cpu="" throttling="">on cpu0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    pcib1: <acpi pci-pci="" bridge="">at device 1.0 on pci0
    pci1: <acpi pci="" bus="">on pcib1
    vgapci0: <vga-compatible display="">port 0xc000-0xc0ff mem 0xf8000000-0xfbffffff,0xfe9f0000-0xfe9fffff,0xfe800000-0xfe8fffff irq 18 at device 5.0 on pci1
    pcib2: <acpi pci-pci="" bridge="">at device 5.0 on pci0
    pci2: <acpi pci="" bus="">on pcib2
    re0: <realtek 8168="" 8168b="" 8168c="" 8168cp="" 8111b="" 8111c="" 8111cp="" pcie="" gigabit="" ethernet="">port 0xd800-0xd8ff mem 0xfdfff000-0xfdffffff,0xfdfe0000-0xfdfeffff irq 17 at device 0.0 on pci2
    re0: Chip rev. 0x3c000000
    re0: MAC rev. 0x00400000
    miibus0: <mii bus="">on re0
    rgephy0: <rtl8169s 8110s="" 8211b="" media="" interface="">PHY 1 on miibus0
    rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
    re0: Ethernet address: 00:21:85:5d:82:ce
    re0: [FILTER]
    atapci0: <ati ata="" controller="">port 0xb000-0xb007,0xa000-0xa003,0x9000-0x9007,0x8000-0x8003,0x7000-0x700f mem 0xfe7ffc00-0xfe7fffff irq 22 at device 17.0 on pci0
    atapci0: [ITHREAD]
    ata2: <ata 0="" channel="">on atapci0
    ata2: [ITHREAD]
    ata3: <ata 1="" channel="">on atapci0
    ata3: [ITHREAD]
    ohci0: <ohci (generic)="" usb="" controller="">mem 0xfe7fe000-0xfe7fefff irq 16 at device 18.0 on pci0
    ohci0: [GIANT-LOCKED]
    ohci0: [ITHREAD]
    usb0: OHCI version 1.0, legacy support
    usb0: SMM does not respond, resetting
    usb0: <ohci (generic)="" usb="" controller="">on ohci0
    usb0: USB revision 1.0
    uhub0: <ati 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb0
    uhub0: 3 ports with 3 removable, self powered
    ohci1: <ohci (generic)="" usb="" controller="">mem 0xfe7fd000-0xfe7fdfff irq 16 at device 18.1 on pci0
    ohci1: [GIANT-LOCKED]
    ohci1: [ITHREAD]
    usb1: OHCI version 1.0, legacy support
    usb1: SMM does not respond, resetting
    usb1: <ohci (generic)="" usb="" controller="">on ohci1
    usb1: USB revision 1.0
    uhub1: <ati 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb1
    uhub1: 3 ports with 3 removable, self powered
    ehci0: <ehci (generic)="" usb="" 2.0="" controller="">mem 0xfe7ff800-0xfe7ff8ff irq 17 at device 18.2 on pci0
    ehci0: [GIANT-LOCKED]
    ehci0: [ITHREAD]
    usb2: EHCI version 1.0
    usb2: companion controllers, 3 ports each: usb0 usb1
    usb2: <ehci (generic)="" usb="" 2.0="" controller="">on ehci0
    usb2: USB revision 2.0
    uhub2: <ati 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usb2
    uhub2: 6 ports with 6 removable, self powered
    ohci2: <ohci (generic)="" usb="" controller="">mem 0xfe7fc000-0xfe7fcfff irq 18 at device 19.0 on pci0
    ohci2: [GIANT-LOCKED]
    ohci2: [ITHREAD]
    usb3: OHCI version 1.0, legacy support
    usb3: SMM does not respond, resetting
    usb3: <ohci (generic)="" usb="" controller="">on ohci2
    usb3: USB revision 1.0
    uhub3: <ati 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb3
    uhub3: 3 ports with 3 removable, self powered
    ohci3: <ohci (generic)="" usb="" controller="">mem 0xfe7fb000-0xfe7fbfff irq 18 at device 19.1 on pci0
    ohci3: [GIANT-LOCKED]
    ohci3: [ITHREAD]
    usb4: OHCI version 1.0, legacy support
    usb4: SMM does not respond, resetting
    usb4: <ohci (generic)="" usb="" controller="">on ohci3
    usb4: USB revision 1.0
    uhub4: <ati 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb4
    uhub4: 3 ports with 3 removable, self powered
    ehci1: <ehci (generic)="" usb="" 2.0="" controller="">mem 0xfe7ff400-0xfe7ff4ff irq 19 at device 19.2 on pci0
    ehci1: [GIANT-LOCKED]
    ehci1: [ITHREAD]
    usb5: EHCI version 1.0
    usb5: companion controllers, 3 ports each: usb3 usb4
    usb5: <ehci (generic)="" usb="" 2.0="" controller="">on ehci1
    usb5: USB revision 2.0
    uhub5: <ati 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usb5
    uhub5: 6 ports with 6 removable, self powered
    pci0: <serial bus,="" smbus="">at device 20.0 (no driver attached)
    atapci1: <ati ixp700="" udma133="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xff00-0xff0f at device 20.1 on pci0
    ata0: <ata 0="" channel="">on atapci1
    ata0: [ITHREAD]
    isab0: <pci-isa bridge="">at device 20.3 on pci0
    isa0: <isa bus="">on isab0
    pcib3: <acpi pci-pci="" bridge="">at device 20.4 on pci0
    pci3: <acpi pci="" bus="">on pcib3
    rl0: <realtek 10="" 8139="" 100basetx="">port 0xe800-0xe8ff mem 0xfebffc00-0xfebffcff irq 21 at device 3.0 on pci3
    miibus1: <mii bus="">on rl0
    rlphy0: <realtek internal="" media="" interface="">PHY 0 on miibus1
    rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    rl0: Ethernet address: 00:06:4f:7a:39:e2
    rl0: [ITHREAD]
    ohci4: <ohci (generic)="" usb="" controller="">mem 0xfe7fa000-0xfe7fafff irq 18 at device 20.5 on pci0
    ohci4: [GIANT-LOCKED]
    ohci4: [ITHREAD]
    usb6: OHCI version 1.0, legacy support
    usb6: SMM does not respond, resetting
    usb6: <ohci (generic)="" usb="" controller="">on ohci4
    usb6: USB revision 1.0
    uhub6: <ati 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb6
    uhub6: 2 ports with 2 removable, self powered
    acpi_button0: <power button="">on acpi0
    atkbdc0: <keyboard controller="" (i8042)="">port 0x60,0x64 irq 1 on acpi0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    speaker0: <pc speaker="">port 0x61 on acpi0
    sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    sio0: type 16550A
    sio0: [FILTER]
    sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
    sio1: type 16550A
    sio1: [FILTER]
    acpi_hpet0: <high precision="" event="" timer="">iomem 0xfed00000-0xfed003ff on acpi0
    acpi_hpet0: HPET never increments, disabling
    device_attach: acpi_hpet0 attach returned 6
    acpi_hpet0: <high precision="" event="" timer="">iomem 0xfed00000-0xfed003ff on acpi0
    acpi_hpet0: HPET never increments, disabling
    device_attach: acpi_hpet0 attach returned 6
    pmtimer0 on isa0
    ppc0: parallel port not found.
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    Timecounter "TSC" frequency 2700110454 Hz quality 800
    Timecounters tick every 1.000 msec
    Fast IPsec: Initialized Security Association Processing.
    hptrr: no controller detected.
    ad4: 152627MB <wdc wd1600aajs-00l7a0="" 01.03e01="">at ata2-master UDMA33
    acd0: DVDR <hl-dt-st dvdram="" gh22ns40="" nl00="">at ata3-master UDMA33
    Trying to mount root from ufs:/dev/ad4s1a</hl-dt-st></wdc></generic></system></high></high></pc></at></keyboard></power></ati></ohci></ohci></realtek></mii></realtek></acpi></acpi></isa></pci-isa></ata></ati></serial></ati></ehci></ehci></ati></ohci></ohci></ati></ohci></ohci></ati></ehci></ehci></ati></ohci></ohci></ati></ohci></ohci></ata></ata></ati></rtl8169s></mii></realtek></acpi></acpi></vga-compatible></acpi></acpi></acpi></acpi></acpi></powernow!></acpi></software></version></lahf,svm,extapic,cr8,prefetch></syscall,nx,mmx+,ffxsr,rdtscp,lm,3dnow!+,3dnow!></sse3,cx16></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,mmx,fxsr,sse,sse2>


Log in to reply