PFsense 2.4.4-p3 Crashing



  • Hi.

    I am new to PFsense and am unable to figure this out.

    My ppfsense firewall keeps crashing every 2-3 hours with the following error

    Fatal trap 12: page fault while in kernel mode
    cpuid = 7; apic id = 07
    fault virtual address = 0x1c
    fault code = supervisor read data, page not present
    instruction pointer = 0x20:0xffffffff80d0cb06
    stack pointer = 0x28:0xfffffe00f60f8930
    frame pointer = 0x28:0xfffffe00f60f8970
    code segment = base 0x0, limit 0xfffff, type 0x1b
    = DPL 0, pres 1, long 1, def32 0, gran 1
    processor eflags = interrupt enabled, resume, IOPL = 0
    current process = 13 (ng_queue6)

    I have made the MBuf changes, switched crypto on and off. Tried different CPU's

    Cannot see what the problem is.

    Its running on a Proxmox server.

    Here is the dump it gives me.

    textdump.tar.0 info.0



  • ng_queue (6) issues ?
    That pretty 'low FreeBSD stuff'.
    It's a kernel thread running on CPU 7 that takes the system down.
    It might be VM related.
    I'm pretty sure this won't happen when you run bare bone (try it out for yourself).

    But, you really don"t have to attribute 8 processors to pfSEnse, or to 2 is more then enough.
    You could also lower the memory size.

    @Riano-desouza said in PFsense 2.4.4-p3 Crashing:

    I am new to PFsense and ...

    ... and you install freeradius3, pfBlockerNG, ,haproxy, acme right away.
    Impressive.



  • @Gertjan

    @Gertjan said in PFsense 2.4.4-p3 Crashing:

    ... and you install freeradius3, pfBlockerNG, ,haproxy, acme right away.
    Impressive.

    Thanks. A lot of google helped.

    Do you think if i lower the CPU count it would help?

    If i cant use it on Proxmox then I wont be able to use pfsense.

    Will test it on a local machine with hyperv or something installed see if that helps.



  • @Riano-desouza said in PFsense 2.4.4-p3 Crashing:

    If i cant use it on Proxmox then I wont be able to use pfSense.
    Will test it on a local machine with hyperv or something installed see if that helps.

    Well, my pfSense test-machines are all running on Hyper-V, because that's the one that is click away in Windows these days, and it works.
    But, I did notice that the opinion on this forum is more for Proxmox. Many people are using pfSense in a Proxmox VM, it should work.


  • Rebel Alliance Developer Netgate

    db:0:kdb.enter.default>  bt
    Tracing pid 13 tid 100057 td 0xfffff80004a40000
    m_copypacket() at m_copypacket+0x16/frame 0xfffffe00f60f8970
    ng_l2tp_seq_rack_timeout() at ng_l2tp_seq_rack_timeout+0x164/frame 0xfffffe00f60f89b0
    ng_apply_item() at ng_apply_item+0x8f/frame 0xfffffe00f60f8a30
    ngthread() at ngthread+0x10a/frame 0xfffffe00f60f8a70
    fork_exit() at fork_exit+0x83/frame 0xfffffe00f60f8ab0
    fork_trampoline() at fork_trampoline+0xe/frame 0xfffffe00f60f8ab0
    

    Looks like it might be related to https://redmine.pfsense.org/issues/9058



  • @jimp

    Cool i just switched off the l2tp server and going to see if it helps. It seems most of those guys struggle with l2tp server so lets see.


  • Rebel Alliance Developer Netgate

    I have one VM in my lab that hits that crash and it has an L2TP WAN, not the server, but either way it's good to know if turning that off helps.



  • @jimp If it makes it through the weekend I will be so happy



  • Its been on for 24 hours. about 22hours longer than it used to be on. It must be the l2tp Interface making it crash.

    edit: its been up for the whole weekend.

    Thanks guys.

    Marking it as Solved.


Log in to reply