• I have physical router. The WAN port will not maintain an IP from Comcast. Other routers don't have this problem. I have used 2 other routers. the Pfsense router will take and hold a IP from a router. The WAN port is set to DHCP. Comcast has done everything they can. The modem is an Arris SB8200. It will get the correct IP from Comcast, but it looses it. It will switch to an IP from the modem, and then, them n/a. I think I am just missing something in the WAN setting.

  • Have you rebooted your modem?

    They will hold on to a MAC address and need to be rebooted each time you change the device on their ethernet port.

    Boot modem and then your pfsense box. Comcast can be a PIA.

  • It has been rebooted, reprovision, and set back to factory default, all while on the phone with Comcast.

  • I have a couple of customers using pfsense on Comcast as well as the boat loads of people that do so here without such issues..

    You can go to your WAN settings and ignore DHCP results from and see if that solves it..

    Im not an Arris fan so have none of those but I do not think that is your issue. Try the above and see if that works first.

  • Any chance you could give me instructions on how to do that?

  • Go to /interfaces.php?if=wan

    Down to "Reject leases from"

Log in to reply