DUVIDA E2GUARDIAN



  • Bom dia !

    Alguem pode me ajudar sabem o que é este ERRO, Não consigo fazer a instalação do e2guardian, apos deletar, toda vez que tento instalar apresenta esta mensagem, e não apararece na Aba services

    obrigado

    Crash report begins. Anonymous machine information:

    amd64
    11.2-RELEASE-p10
    FreeBSD 11.2-RELEASE-p10 #9 4a2bfdce133(RELENG_2_4_4): Wed May 15 18:54:42 EDT 2019 root@buildbot1-nyi.netgate.com:/build/ce-crossbuild-244/obj/amd64/ZfGpH5cd/build/ce-crossbuild-244/pfSense/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [16-Sep-2019 16:38:20 America/Sao_Paulo] PHP Fatal error: Uncaught Error: Cannot use string offset as an array in /usr/local/pkg/e2guardian.inc:711
    Stack trace:
    #0 /usr/local/pkg/e2guardian.inc(2056): sync_package_e2guardian('no', true)
    #1 /etc/inc/pkg-utils.inc(770) : eval()'d code(3): e2guardian_php_install_command(false, true)
    #2 /etc/inc/pkg-utils.inc(770): eval()
    #3 /etc/inc/pkg-utils.inc(858): eval_once('update_status("...')
    #4 /etc/rc.packages(74): install_package_xml('E2guardian5')
    #5 {main}
    thrown in /usr/local/pkg/e2guardian.inc on line 711
    [16-Sep-2019 16:40:53 America/Sao_Paulo] PHP Fatal error: Uncaught Error: Cannot use string offset as an array in /usr/local/pkg/e2guardian.inc:711
    Stack trace:
    #0 /etc/inc/pkg-utils.inc(707) : eval()'d code(1): sync_package_e2guardian()
    #1 /etc/inc/pkg-utils.inc(707): eval()
    #2 /etc/rc.start_packages(63): sync_package('E2guardian5')
    #3 {main}
    thrown in /usr/local/pkg/e2guardian.inc on line 711

    No FreeBSD crash data found.



  • Alguém com mesmo problema ?



  • Fala @Fernando-Ramaldes , beleza?
    Cara, não sou expert em pfSense, mas segui as orientações dos vídeos abaixo e não tive nenhum problema na instalação do E2Guardian.

    1. https://www.youtube.com/watch?v=rHmvAtt5Ybw&feature=youtu.be
    2. https://www.youtube.com/watch?v=NuhxsyatYAs
    3. https://github.com/marcelloc/Unofficial-pfSense-packages

    Boa sorte aí!



  • This post is deleted!


  • @rangel-glauco
    muito Obrigado Rangel vou seguir o passo a passo se estiver certo aqui ou o resultado



  • @rangel-glauco
    Efetuei todos os procedimentos porem não houve sucesso se souber de mais algum agradeço, desde já muito obrigado .



  • Bom dia Fernando.
    Que pena que não deu certo.

    Como disse não sou expert, mas analisando o erro que você relatou, parece ser algum problema relacionado a "lixos" que ficaram da instalação anterior, que você deletou.

    Minhas recomendações:

    1. Se estiver usando o pfSense em uma VM (máquina virtual), tente voltar pra algum screenshot anterior à primeira instalação que você fez do E2Guardian e então siga os passos dos links que lhe informei;

    2. Faça o backup das suas configurações atuais do pfSense, através do menu "Diagnostics -> Backup & Restore ->Backup Configuration", em seguida faça uma nova instalação do pfSense, restaure as configurações que você salvou e então siga os passos dos links que lhe informei;

    Acredito que terá sucesso seguindo umas destas recomendações.

    Boa sorte e fico à disposição.



  • @rangel-glauco
    Deu certo VALEUU pela ajuda


Log in to reply