Wireless devices unable to access network devices



  • New to pfsense. I am having an issue with my wireless devices. My desktop pc (192.168.1.101) is able to access files on my freenas and can print fine. But anything connected through my Asus RTN66U is unable to access the printer or freenas. I disabled DHCP and assigned a static ip of 192.168.1.2 to the asus router. I even tried putting it in access point mode. My laptop is able to connect to the internet fine but is unable to ping the asus router or the printer or the freenas. Network Layout.jpg



  • @Spawn_2_extreme said in Wireless devices unable to access network devices:

    I even tried putting it in access point mode.

    What do you mean "I even tried..."? That's what you should be doing. You don't want your Asus acting as a router or dhcp server. You just want it bridging to LAN.

    Disable Asus WAN port (if possible) & unplug it
    Disable DHCP server
    Connect Asus LAN port to LAN switch

    https://docs.netgate.com/pfsense/en/latest/wireless/use-an-existing-wireless-router-with-pfsense.html

    Also, in your config everything is on the one network so pfSense isn't involved at all with this problem. It's strictly between your Asus, your wireless clients and your NAS.



  • Thanks, disabling the wan port, fixed my issue.


  • Netgate Administrator

    Do you see the laptop in the pfSense DHCP leases table in Status > DHCP leases?

    I expect you will otherwise you would have bigger problems than just not being able to access the printer.

    That traffic should go directly between your laptop and the printer if the Asus is acting purely as an access point. pfSense never sees that traffic and hence cannot block it.

    Steve


Log in to reply