Poor LAN performance with QOTOM Q330G4?



  • I bought :

    CPU: Intel Core i3-4005U (3M Cache, up to 1.70 GHz) with AES-NI support
    LAN: 4* Intel I211AT - 10/100/1000 Controller
    Power Consumption: 15W
    Memory: 1 DDR3L SODIMM slot with 8GB Memory pre-installed, 1333/1600 MHz, 1.35V
    Hard Disk: 16GB SSD pre-installed; supports mSATA / 2.5" SATA
    Cooling: Fanless, passive
    Integrated Graphics: Intel HD Graphics 4400
    Audio: Realtek ALC662 6-Ch HD Audio

    I installed pfsense on it with no special coinfiguration applied. I installed speedtest-cli on it.

    When I run it I got on Download 120mbps witch is the internet connection.

    When I run a speed test on a computer plug on the lan of pfsense I got 32Mbps.

    The setup: [Internet] - Modem - QOTOM - Computer

    Is it normal? Anyone have benchmarked a QOTOM Q330G4?

    Thanks



  • Curious, when you say modem, it's not a modem router combo is it? I also went with a Qotom, this one Q655G6 with Intel Core i5-7400 Processor, Quad core, AES-NI (8G DDR4 RAM+128G M.2 SSD) with 6X Gigabit Intel LAN Ports. I have a 1G fiber line going to the ONT and them the Qotom and I see 900+ up and down.


  • Netgate Administrator

    With that sort of throttling I would look for something low level. Check the interface status for errors.

    Swap out cables.

    Try assigning LAN to a different port.

    Steve



  • The modem is an "wifi modem ac wave 2 docsis 3.1 moca". Yes it is a modem router combo but the LAN mode and wifi is disabled. It only assign Internet provider's IP address.

    If I plug a computer behind it I get full speed.

    It is sure that a Core i5-7400 has more power into it and it would be normal to have less power.
    What can I expect from my i3?

    I will try other port this weekend.

    Thanks


  • Netgate Administrator

    Almost anything should pass 120Mbps. There is something very wrong if you cannot get more than 32Mbps.

    Check for hardware problems like a bad cable or bad port/NIC.

    Steve



  • Thanks


Log in to reply