pfSense dropping my Internet connection / WAN IP



  • Hello there,

    i'm new to pfSense, hopefully i'm using the right forum for this kind of (configuration?) issue.

    Here is some information on how i'm running pfSense.

    Host is a Zotac Mini PC (CI327), it has Debian Buster installed which is running Proxmox. I followed the Proxmox guide on how to install pfSense as VM. The VM has 4 cores and 6Gb RAM assigned just to make sure that this is not a hardware limitation issue.

    The issue itself: My WAN IP changes throughout the day and the only way to fix it is to open Status > Interfaces page and click on Release > Renew until i get my public IP back. It's really frustrating. I changed barely anything in pfSense because i want to get this working first.

    WAN is set to DHCP. I've tried to disable Gateway Monitoring and Gateway Monitoring Action, but it had no effect. Gateway IP is 1.1.1.1

    Here is a snippet of my system log

    09:12:59	check_reload_status rc.newwanip starting vtnet1
    09:13:00	php-fpm	/rc.newwanip: rc.newwanip: Info: starting on vtnet1.
    09:13:00	php-fpm	/rc.newwanip: rc.newwanip: on (IP address: 192.168.1.99) (interface: WAN[wan]) (real interface: vtnet1).
    09:13:00	php-fpm	/rc.newwanip: IP Address has changed, killing states on former IP Address 123.456.789.0.
    09:13:46	php-fpm	/status_interfaces.php: Successful login for user 'admin' from: 192.168.1.86 (Local Database)
    09:13:57	php-fpm	/rc.newwanip: Resyncing OpenVPN instances for interface WAN.
    09:13:57	php-fpm	/rc.newwanip: Creating rrd update script
    09:13:59	php-fpm	/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection 123.456.789.0 -> 192.168.1.99 - Restarting packages.
    

    Any ideas?


  • LAYER 8

    who is assigning you the 192.168.1.99 ? do you have another dhcp server running somewhere?
    i suppose you should have a public ip there instead .. ?
    in the advanced option of your WAN interface there is

    Immagine.jpg



  • Yes usually there is the public IP. I do have a DHCP for my LAN but i doubt that this is the issue here. Either way i entered the DHCP server ip, will see if this changes anything.


Log in to reply