gateway group : ending up with no default route after a network restart while the gateways where ok



  • hello all

    i have a setup with a firewall pair and multiple gateways in a group. tier1 is a single gateway monitored with 1.1.1.1, other gateways use similar setups but different ping ips

    i recently added a network interface and restarted the master firewall services using rc.reload_all

    the carp vips switched back and forth as expected : the statuses on both firewalls were consistent.

    nevertheless the default gateway was deleted and only came up again after is manually switched to one of the gateways

    i switched back to the group without further issue

    i could see a few complaints from dpinger stating it detected over 20% packet loss but that was only punctual and i assume due to carp

    in the general log, there is no log from /system_gateway_groups.php between the carp failover and the moment i switched thing back manually

    any ideas regarding how to debug further ?

    any way to instruct pfsense to keep the first gateway active at all times ?

    anyone knows which component deals with the gateway changes ?

    if i remove all routes, will pfsense toy with my configuration ? i have existing working scripts for gateway failover and can use them

    thanks for your time



  • @skullnobrains said in gateway group : ending up with no default route after a network restart while the gateways where ok:

    any way to instruct pfsense to keep the first gateway active at all times ?

    errata : i mean stick in the first gateway whenever pfsense detects none are working


Log in to reply