Issues with PFSense VMware installation, http connectivity, php error.



  • Hello Everyone,
    Currently working on Installing PFSense in a VMWare environment.
    Ran into some weirdness with connectivity, I have the Default Gateway on FreeBSD set to the Gateway on our management network, using the "route add default <IP>" shell cmd. This had to be done due to the fact that the device I am going to be managing it from is in a different subnet than what is directly connected to the LAN interface.
    Currently nothing is setup on the WAN interface.
    Currently enabled http for testing due to https not working at all.
    Port Scan identifies that port 80 is open:
    5e02a0c1-c06d-428f-8134-328f07d46bdc-image.png
    When I connect, I get a wall of text with a PHP error at the end of it. Attaching Picture(Using IE just for testing, I have tried it in the latest version of Firefox as well):
    23bbcb80-8793-45ab-b31d-551a9a071f30-image.png

    I am no expert, but this next picture seems to be a manifestation of the issue, but I am not knowledgeable enough to determine what it means:
    9f06f75f-592e-4c23-a5a1-05e3baf6ff55-image.png

    This result stays the same no matter how many times I restart the web configurator and PHP-FPM.
    I have done a factory reset and this hasn't changed the outcome.
    I have not yet tried a Reinstall of the system, but if it comes to that, then it comes to that.

    I appreciate any help you can give me.
    Thanks,
    ~Yo


  • LAYER 8

    probably there is something wrong with your installation, a factory reset will only reset the config.xml to the default value but it will not correct errors on files.
    you need to reinstall


Log in to reply