pfSense + Catalyst 3750G



  • I installed PfSense for my first time ever last night, everything went smooth, I set it up with the same IP as my R8000 router I wanted to replace (R8000 needs to be turned off alsmost weekly before it starts to slow down, even with DD WRT on it). I connected my PC and the Internet connection to it, and everything worked, until I swapped the pc for the 3750G, now PfSense keeps repeating "Gigabit link up!" non stop

    My PfSense box is a Dell R410 with a 2 port NIC

    pfSens Lan Port 10.0.0.1/24
    Switch port 10.0.05/24

    The 3750G has 2 VLANS with IP Routing enabled, everything works as soon as I place my R8000 back into place, but when I go back to PfSense it won't connect, the port on the switch won't light up and then PfSense starts displaying tthat message non stop.
    I even tried changing the port to trunk with Dot1Q and allowing the vlans, I also tried dhcp on that port and the PfSense and it won't work

    Any ideas what could be causing this


  • LAYER 8 Netgate

    Please you post the actual logs you're seeing. Gigabit link up! does not sound like anything I have ever seen pfSense report.



  • May not be applicable at all, but in days of yore when I ran pfSense 1.2.3 on a Nokia ip530, I had to enable Device Polling in order to stop a vague ""interrupt storm on IRQ12" spam in console. But the feature has been removed in 2.4 (likely for good reason) FWIW.

    Are your link settings set to auto/full/what?



  • Yeah at first I thought it was a negotiation problem, but I tried auto, and full duplex to no avail.
    Its like the pfSense lan port is rejecting the switch, but when I swap back to this pc is fine, Im using the pfSense box right now as a router. I ordered a quad port NIC , because this swapping is really getting old. Once I swap to the switch I can't see Web UI so that I can monitor the problem


  • LAYER 8 Netgate

    Set the pfSense interface like this:

    Screen Shot 2019-10-06 at 11.39.15 AM.png

    And I still don't see any actual logs.



  • Maybe a sketchy port or cable but you've probably checked that. Dunno.



  • @Derelict Oct 6 13:59:24 kernel bce1: link state changed to DOWN
    Oct 6 13:59:24 php-fpm 41751 /rc.newwanip: rc.newwanip: Info: starting on bce1.
    Oct 6 13:59:24 php-fpm 41751 /rc.newwanip: rc.newwanip: on (IP address: 10.0.0.1) (interface: LAN[lan]) (real interface: bce1).
    Oct 6 13:59:24 check_reload_status Reloading filter
    Oct 6 13:59:25 php-fpm 41751 /rc.linkup: Hotplug event detected for LAN(lan) static IP (10.0.0.1 )
    Oct 6 13:59:27 check_reload_status Linkup starting bce1
    Oct 6 13:59:27 kernel bce1: Gigabit link up!
    Oct 6 13:59:27 kernel bce1: link state changed to UP
    Oct 6 13:59:28 check_reload_status Linkup starting bce1
    Oct 6 13:59:28 kernel bce1: link state changed to DOWN
    Oct 6 13:59:28 php-fpm 372 /rc.linkup: Hotplug event detected for LAN(lan) static IP (10.0.0.1 )
    Oct 6 13:59:28 check_reload_status rc.newwanip starting bce1
    Oct 6 13:59:28 check_reload_status Reloading filter


  • LAYER 8 Netgate

    OK it's out of the bce driver then.

    Is that LAN interface set as I mentioned before?

    What do the switch logs say?



  • yeah I had left it at default after messing with it, and the switch port I changed it to auto also.

    The switch acts like nothing is happening at all, no lights up, no change in state of link nothing.
    And to try it out, I just plugged the R8000 back into the switch and it linked up


  • LAYER 8 Netgate

    Welp. Really difficult to say. I'd suspect a cable. Problems with Cisco switches and bce NICs hasn't come across my radar before. If the switchport is not coming up at all I can see the NIC complaining though.

    My guess is if you connect that bce to anything else it will link up just fine. Not sure what you might need to change on that switch.



  • Yeah really weird, Im back on my R8000 as router connected to that same switch with the same cable and everything is working. It just won't play nice with the pfSense box



  • Sounds like "Port flapping"? Maybe Google that with "3750". Maybe it's a firmware deal. Was this port part of a bundle previously? Try moving the port config to another port?


  • Netgate Administrator

    Try swapping the bce0 and bce1 port assignment. If it's a bad port it may follow that.

    Steve



  • So after using port 24 with my R8000
    I decided to shutdown that port and set an IP on port 23
    And pfSense now detected my switch and vice versa (sigh)
    Port 24 on switch works with Pc, and R8000 but not with pfSense go figure

    Now I need to figure out how to NAT on pfSense all my vlans behind the 3750G

    Thanks a much for the input

    I see this community is active and very helpful


  • LAYER 8 Global Moderator

    @Manguu said in pfSense + Catalyst 3750G:

    Now I need to figure out how to NAT on pfSense all my vlans behind the 3750G

    If your using auto outbound nat, it will auto do it for you once you create the gateway and the routes to the downstream router (your 3750).. All you will have to do is make sure the rules on your transit interface (the interface that gets to the 3750) allows the downstream networks in its rules.


Log in to reply