thermal sensor widget does not work

  • ENV: pf 2.4.4-RELEASE-p3, CPU: i3-7100U

    From System > Advanced > Miscellaneous : Thermal Sensors section, I have changed settings to Intel Core CPU on-die Thermal sensor; however, I 'Thermal Sensor' widget does not show anything other than 'Updating...':

    I have tried switching back-and-forth to None to Intel Core CPU.., but with no success. Any idea why I'm not able to get the temperature reading?

    Thank you.

  • That's odd, I have the exact same CPU and software version, and my thermal sensors work fine (with the Intel Core CPU setting):
    Software and CPU info

    Thermal sensors on my system

    Have you poked through your BIOS settings? Some BIOSes have options to enable or disable on-die thermal sensors, and you may also need to enable the "ACPI aware OS" option (or something similar) to allow the software to read the sensors.

  • Netgate Administrator

    Check the system logs. When you enabled that you should see something like:

    Oct 1 22:11:45 	kernel 		coretemp0: <CPU On-Die Thermal Sensors> on cpu0
    Oct 1 22:11:45 	kernel 		coretemp1: <CPU On-Die Thermal Sensors> on cpu1
    Oct 1 22:11:45 	kernel 		coretemp2: <CPU On-Die Thermal Sensors> on cpu2
    Oct 1 22:11:45 	kernel 		coretemp3: <CPU On-Die Thermal Sensors> on cpu3 


  • @Doktor-Jones Hi there! Thanks for your response!

    Interesting that I have the same CPU, but I don't see the "2 Hardware Threads":

    I have looked at the BIOS, but nothing sticks out:

    I have tried enabling/disabling DTS SMM as well as ACPI Settings to no avail. Can you share your BIOS settings if your system is running American Megatrends BIOS?

  • @stephenw10 Hi Steve. tail /var/log/system.log | grep -i temp does not return anything. tail /var/log/system.log | grep -i cpu returns:

    CPU: Intel(R) Core(TM) i3-7100U CPU @ 2.40GHz (2400.00-MHz K8-class CPU)
    FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    SMP: AP CPU #1 Launched!
    cpu0: <ACPI CPU> numa-domain 0 on acpi0
    cpu1: <ACPI CPU> numa-domain 0 on acpi0
    CPU: Intel(R) Core(TM) i3-7100U CPU @ 2.40GHz (2400.00-MHz K8-class CPU)

  • Well for the two cores, you will probably need to go into CPU Configuration and enable hyperthreading; looks like it's disabled on your system. You might find settings either in there or in IT8772 Super IO Configuration or Hardware Monitor for enabling the thermal sensor (but not sure).

    Is your system a prebuilt or did you build it yourself? If prebuilt, where did you get it? This is the system I've got. It has an American Megatrends BIOS, but options can vary by board manufacturer and/or system builder.

    I might be able to get screenshots of my BIOS settings tomorrow, but my system is in use as my home router now and my S/O and her son would literally tear me limb from limb if I took down the internet to take screenshots 😨

  • @Doktor-Jones I have the exact same system (FW6B)! I'll check the hyperthreading configuration. As for BIOS screenshots, no worries or rush. Don't want you to be in the 'dog house' for my sake ;-) Would appreciate the screenshots though when it's safe to do so 8-)

  • @Doktor-Jones Under CPU Configuration, Hyper-Threading already shows as 'Enabled'.

    Under Thermal Configuration->CPU Thermal Configuration, all values are set to Default. I had previously attached a screenshot of that screen. Let me know if you think of something else.

    Thanks again!

  • That's interesting... @stephenw10 any thoughts on why @rsaanon is only seeing two cores if HT is enabled?

    Does the Hardware Monitor option have any settings, or is it just a read-only view of current values. Does it at least show CPU temp?

  • @Doktor-Jones Hardware Monitor is ready-only with current values. Yes, it does show the current CPU temperature.

  • Netgate Administrator

    It's possible to disable hyperthreading in FreeBSD/pfSense but it isn't by default.

    [2.4.4-RELEASE][admin@5100.stevew.lan]/root: sysctl machdep.hyperthreading_allowed
    machdep.hyperthreading_allowed: 1

    I've never seen cputemp disabled for a CPU that supports it. It sounds like that CPU may not be setup correctly some how.
    Different BIOS version perhaps?


  • I'm going to be rewiring my home network this weekend (many of the cables are hand-crimped cat5). Although they still seem to be getting the job done and everything is negotiating at 1000, I figure as long as I'm pouring money into network upgrades, I should upgrade the cables too to pave the way for gigabit-plus speeds. Since bulk cat5 is expensive, I often bought the cheapest box, and sometimes cannibalized other cables and other weirdnesses... I figure it's high time to purge that.

    When I take things down to do the rewire, I should have a chance to shut down the router and take screenshots of the BIOS. I'll be sure to get version number as well as the various settings. I suppose one nice thing about having a serial console is I can literally just copy/paste the text from the BIOS screen 😁

Log in to reply