pfsense, bridge gbic fiber question



  • I grabbed a dell t1700 and it works really well.

    I recently instgalled a Dell Y40PH Broadcom Dual Port 10GB SFP+ Fiber PCI-e x8 Fibre Low Profile w/ SFPs and then installed a Emulex P005414 10GB Dual Port PCI-E Fibre Channel Network Adapter into my computer. I have connected both 850/multimod 3 meter and 2 meter fiber and I've also connected a 10G SFP+ DAC Cable - 10GBASE-CU Passive Direct Attach Copper Twinax SFP Cable 2 meter.

    It seems like it takes forever for the interfaces to come up i/e be usable, getting it's dhcp info.

    I've put the 3 interfaces (1 gb copper and the 2 gbic interfaces into a bridge.

    What other settings do I need to get these fiber interfaces to come up quicker? It seems to take these things about 15 - 30 minutes to come up. Is that normal?

    Thanks in advance!



  • @teddygramps said in pfsense, bridge gbic fiber question:

    It seems to take these things about 15 - 30 minutes to come up.

    So, are you saying that when you boot your pfSense box, it takes 15 - 30mins for the interface to get IP addresses? That seems not normal. I had to increase my WAN time to 15mins (900sec) whenever I reboot the cable modem so my pfSense box wait and not give 0.0.0.0 or N/A for IP address...but that's only when the modem needs to reboot. Still, it usually gets an address within 2mins.
    Screen Shot 2019-10-14 at 10.18.45 PM.png


  • Netgate Administrator

    @NollipfSense said in pfsense, bridge gbic fiber question:

    That seems not normal.

    Massive understatement! It should take no time.

    In a bridge configuration on one interface should have an IP so I assume you mean these take that long just to come UP with link?
    Check the system log for errors.

    Steve



  • Well what I run into is the interfaces on my computer itself. See, I have a 2 port fiber card on the pc connected to a 2 port fiber card on the pfsense box. On the pfsense box, I have lan and opt1 and opt2 in a bridge connection. I've increased the timeout for the dhcp leases, but that didn't help. On the windows box, I have to continue to do a ipconfig /renew all and then the fiber interface on the windows box comes up. When I first boot, I can't even get into the pfsense box.

    I've tried different 10 gig fiber adapters, the best I've seen so far the cisco. I have an emmulex card on the windows box, and dell card on my dell pfsense box.

    I'm using lc connectors, multi mode fiber.

    I'm not sure what setting I need to adjust.

    It's getting to be a pain. Even in the middle of doing something, the fiber connection just stops. Don't know what causes it. I'd like to check the logs, but I'm not sure, are they all in /var/log?

    Thanks for the responses and the help!!

    Teddygramps



  • Think I found the problem. The cards are ones I have purchased from ebay.

    Emulex oce11102
    chelsio cc2-n320e-sr

    These cards run too damned hot and were designed by the little kids who
    get their butts beat when they don't sew enough shirts at their other factory
    in pakistan.

    I can use the emulex, but I have to have a personal size fan blowing on it
    to keep it cool for it to run.

    The Dell 0Y40PH run really well. They have a small fan that helps keep
    the card's heatsink cool.

    I still see a small amount of lag time for dhcp, steam starts before the interface
    is up and running. So, I may static it and see what happens.

    So, it's been another interesting lesson....

    Thanks for all the help!!!



  • @teddygramps
    And on those dell cards, be careful many are small form factor. These cards won't fit in a regular size atx motherboard setup. There are people who do sell the proper bracket out of china.


Log in to reply