LAN can resolve name, but no internet access.



  • Hello,

    I'm having a bit of trouble in my pfSense install.
    I have two interfaces, WAN (PPPoE) and LAN (with DCHP server). I'm connected to the internet in the WAN and my computer connected to the LAN receives an IP just fine.
    I created one rule for the WAN interface to allow all traffic, and it seems to be working, since I can ping anything (google.com for example), and likewise a rule to allow all in the LAN interface, but while I can resolve names, I can't even ping from LAN.

    PING netgate.com (208.123.73.73) from 192.168.30.1: 56 data bytes
    
    --- netgate.com ping statistics ---
    3 packets transmitted, 0 packets received, 100.0% packet loss
    

    Searching for this problem I found that some people had to check the "Disable hardware checksum offload" box in Settings > Advanced > Networking. I did the same, but nothing changed. I'm not sure what I'm doing wrong here.

    Thanks in advance.



  • You do not create any rule on WAN to allow LAN internet access.

    The default LAN rule should allow traffic just fine. pfsense comes default to allow internet access to the LAN.

    Delete the WAN "allow all" rule as that is a security issue. Then show a screenshot of your LAN rules..



  • Capture.PNG
    OPT1 is my LAN connection.



  • Your rule is fine. The WAN rule you added should be deleted immediately. As @chpalmer said, you don't need rules on WAN. WAN rules are only to allow unsolicited traffic in from the Internet. Start here:

    https://doc.pfsense.org/index.php/Connectivity_Troubleshooting



  • Capture.PNG
    I already deleted the rule on WAN. I'm looking at the link you posted and this is my firewall log.

    After rebooting it works now. So, if anyone has this problem rebooting might help. Thank you guys.


Log in to reply