Issue in the UI setting up a USB GPS Device.



  • Im having some issues with setting up a USB GPS device.

    The issue seems to lie in the UI of pfsense, where the baud rate is chosen i move it to 9600 baud from the standard 4800 baud and upon save the setting is reverted back to 4800 bauds.

    Didn't find a NTP section in the forums so i leave this here...

    Has anyone else experienced the same issues? It worked on my old pfSense (2.3) but now after i updated to an 64bit system with the newest version the settings seem to not update...

    Anything else is updated as is selected but the baud rate jumps back to the original all the time.



  • Update:
    The gps kicked in but the UI is still showing 4800 and not 9600 like it is set to.


  • Netgate Administrator

    Where and what exactly are you setting here? Can we see some screenshots?

    Steve



  • Services  NTP  Serial GPS - BLACKGATE akr is.png



  • Status  Dashboard - BLACKGATE akr is (1).png


  • Netgate Administrator

    Hmm, not sure what the problem is. 4800bps is clearly the correct baud for your GPS module. If you want to use anything different you have to send it the initialisation commands to change the baud rate and then things get complex because you have to send those commands at the default baud!
    Is there some reason you want to use 9600 rather than 4800?

    Steve



  • @stephenw10 that is actually the issue,

    It is the UI that is displaying wrong results, because if i try to read from my GPS module on 4800 bauds then it doesn't work, the gps module is spitting out at 9600 bauds, confirmed that with a connection in screen with screen /dev/cuaU1 9600 and all the information came through, did the same with 4800 and its scrambled.

    Somehow it is running at 9600 bauds now and getting the correct values, but the UI is showing that is is 4800.


  • Netgate Administrator

    Hmm, I see. What do you see in /var/etc/ntp.conf?

    It's clearly actually running at the correct speed as you say. Odd though. I have devices set at 4800 and 9600 and they work OK. Though the 9600 device is running 2.5, can you test a snapshot?

    Steve



  • @stephenw10

    #
    # pfSense ntp configuration file
    #
    
    tinker panic 0
    # Orphan mode stratum
    tos orphan 12
    
    # GPS Setup
    server 127.127.20.0 mode 22 minpoll 4 maxpoll 4 prefer
    fudge 127.127.20.0 time2 0.400 flag1 1 flag3 1
    
    
    # Upstream Servers
    pool 0.pfsense.pool.ntp.org iburst maxpoll 9
    
    
    statsdir /var/log/ntp
    logconfig =syncall +clockall
    driftfile /var/db/ntpd.drift
    restrict default kod limited nomodify nopeer notrap
    restrict -6 default kod limited nomodify nopeer notrap
    restrict source kod limited nomodify notrap
    interface ignore all
    interface ignore wildcard
    interface listen em0.10
    interface listen em0.40
    interface listen em0.50
    interface listen ovpns1
    interface listen em0
    

    Thats all that is in ntpd.conf, ntp.conf does not exist...

    This is a line from the /var/log/ntpd.log

    Nov  4 19:00:40 XXXXXXXXX ntpd[7674]: GPS_NMEA(0) serial /dev/gps0 open at 9600 bps
    

    So the device is somehow reading at 9600bps but the interface is not showing that, and obviously i'll have to make the change to 9600 every time i need to change other options in there (not that that happens alot)


  • Netgate Administrator

    Hmm, I forget where the gps target port is set now. I'll have to dig later when I have time...



  • @stephenw10

    Yeah i have been searching for that too, haven't found it yet...


Log in to reply