Whatsapp no Bypass, Squid para de funcionar na mesma hora


  • Pessoal, estou com um problema que está tirando minhas noites de sono.
    Todos sabem que o "web.whatsapp.com" não funciona passando pelo proxy.
    o Problema é que quando eu coloco ele no Bypass, meu squid+squidguard simplesmente param de funcionar na hora, o serviço continua rodando, mas ele para de filtrar tudo. (dessa forma, como o proxy para de funcionar, ele acessa o whatsapp normalmente)

    Se eu excluo ele do Bypass, volta a funcionar todos os bloqueios novamente.

    Alguem ja passou por isso ?

    Minhas configurações:
    Proxy transparente
    Pfsense 2.4.4
    Squid 0.4.44_8


  • Amigo, eu já tive um problema semelhante no E2Guardian quando eu colocava mais de um endereço.
    É o seu caso? Estar com mais de um endereço no campo by pass? Se for, testa criar um alias e coloca os endereços nele, ai coloca só o alias no by pass.
    Veja se isso lhe ajuda algo, não tenho o ambiente com squid+squidguard para lhe passar a certeza :(


  • Agradeço a dica amigo, acontece colocando tanto sozinho, como junto com outros alias de bancos por exemplo.

    Por incrível que pareça, no e2guardian acontece exatamente a mesma coisa, quebrei tanto a cabeça com o squid e não deu certo, que tentei o e2guardian também, como deu a mesma coisa voltei pro squid.

    OBS: estou colocando assim: w1.web.whatsapp.com

    Tanto com alias como o endereço direto no bypass, se eu coloco somente web.whatsapp.com, o squid funciona normalmente, mas o whatsapp continua sem funcionar


  • Pessoal, Estou com o mesmo problema, se eu colocar qualquer informação no bypass, ip, alias ou host o Squid para de filtrar sites. Se alguém já descobriu alguma coisa por favor poste aqui!


  • @ENC

    Depois de quebrar muito a cabeça aqui, consegui resolver da seguinte forma:

    Na opção SSL/MITM Mode, selecionei a opção CUSTOM.
    Depois la embaixo clique no Botão "Show Advanced Options"

    No ultimo campo Custom Options (SSL/MITM), insira os sites que você quer fazer bypass, da seguinte forma:
    (só copiar e colar, adicionando os dominios)

    acl splice_it ssl::server_name .whatsapp.com
    acl step1 at_step SslBump1
    ssl_bump peek step1
    ssl_bump splice splice_it
    ssl_bump bump all


  • Opa! Deu certo aqui da maneira que você disse @michael.lopes ! Obrigado!