pfBlockerNG GeoIP "no valid package defined"

  • Re: PfBlockerNG Error

    Same problem as previously reported. GeoIP data isn't being downloaded after several reinstalls of pfBlockerNG version 2.1.2_1.

    I don't see the development version of pfBlockerNG in my available package list either, so that solution isn't available to me.

    I am able to view the MaxMind pages using a browser behind the pfSense router.

    During install, the log shows:
    "Executing custom_php_install_command()...
    Downloading MaxMind GeoIP databases. This may take a minute...
    GeoIP.dat... Failed!
    MaxMind download Failed! Fetching MaxMind archive from pfSense package repo...
    /tmp/countrycodes.tar.bz2 0 B 0 Bps
    Fetch done.
    Converting MaxMind GeoIP databases for pfBlockerNG.
    This may take a few minutes...
    Country code update Start [ 11/13/19 11:05:43 ]
    [ MAXMIND UPDATE FAIL, Language File Missing, using previous Country code database ]"

    FYI only: MaxMind's web page has a notice about an October website change from http to https. No idea if that is relevant to this problem.

    pfSense is version 2.3.4-RELEASE-p1 (i386)

    Any ideas about what I can try next?

  • Rebel Alliance Developer Netgate

    @telserv said in pfBlockerNG GeoIP "no valid package defined":

    pfSense is version 2.3.4-RELEASE-p1 (i386)

    You need to upgrade to a supported version of pfSense. That is too old.

  • Under "Status | Dashboard", it reports "The system is on the latest version", which is a bit confusing.

    However, this unit is an older PC that was pulled off the shelf and jammed into service after a network problem, so I don't doubt it has old software on it. I was just confused by the 'latest version' message. Thanks for the reply.

  • Rebel Alliance Developer Netgate

    It's running i386, and 2.3.x is the latest version available for that, because we do not support i386 on 2.4.x and later. 2.3.x has been EOL for over a year:

    If that hardware is capable of running a 64-bit OS, you can reinstall with the latest 2.4.4-p3 installer and get back up and running. If that hardware is 32-bit only, it will need to be replaced.

Log in to reply