Stuck at booting after upgrade to version 2.5.0 development snapshot



  • Hi,

    I was trying to experiment the version pfSense 2.5.0 development snapshot but after rebooting and accessing the web interface, I configured the WAN port, etc... Then I clicked Finish and the device rebooted and now is in looping with this message:

    Warning: Cannot use a scalar value as an array in /etc/inc/config.lib.inc on line 383

    Using console interface I can see the messages and I can stop the loop pressing CTRL+C but I dont know how reload pfsense.

    Can you guys have some tip to fix that?

    My Config: NETGATE SG-3100

    Thanks in advance,



  • Ok, I managed to recover Netgate from the error above the problem was one zero byte config.xml, after copy other config.xml from backup at least the boot and web interface worked.

    But now I discovered another problem, in Interfaces | Switches | Ports I have this message:

    The following input errors were detected:
    Cannot get switch device information

    Wan and Lan works but the other interfaces disappeared.

    Any tips?


  • Rebel Alliance Developer Netgate

    The switch issue appears to be a general problem on 2.5.0 right now, at least on the 3100.


Log in to reply